Can't correctly import mail from Eudora-J

VERIFIED FIXED

Status

MailNews Core
Internationalization
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: ji, Assigned: m_kato)

Tracking

({intl})

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
********Observed with Win32 2000103009-mn6 build**********

When importing Mail from Eudora 4.3 Japanese, the Japanese default mailboxes and Ja mails are not converted correctly.

Steps to reproduce:

1. Have one Japanese mail in Eudora 4.3-J.
2. Launch Netscape 6 Mail.
3. Setup Mail account. ( If I don't set up Mail acount first, the eudora mail can't improted at all. The import wizard looks like
    working, but after improt is finished,  Eudora mailboxes don't show at all. This must be a seperate core bug.)
4. Select Task | Tools | Import Utility
5. Check on Mail and click on Next
6. Select Eudora and click on Next
    Then you'll see Eudora's defaul mailboxes in Japanese: In, Out and Trash are displayed garbled on converting screen.
    (I'll attach a sreenshot later).
    And a warning message window pops up, saying that "This message contains characters not found in the chosen Character 
Coding, The message may be unreadable to recipient. Send it anyway or "Cancel" to choose a different Character coding."
7. Click on OK, let it continue. Then the import wizard seems ending, click on Cancel to close the wizard.
8. Go to Mail mail window, you'll see Eudora account is created, but all the Japanese mailboxes from Eudora are garbled.
    If you select one of them, it's loading forever.

There are two problems here:
1. Import utility can't handle the Japanese default mailboxes in Eudora-J. 
2. The mail converting from Eudora to Seamonkey seems not working properly.
(Reporter)

Comment 1

18 years ago
Created attachment 18557 [details]
Ja mailboxes are displayed garbled on import wizard.
(Reporter)

Comment 2

18 years ago
Created attachment 18558 [details]
Ja mailboxes from Eudora are not accessible.
(Reporter)

Updated

18 years ago
Summary: Can't import Mail from Eudora-J → Can't correctly import mail from Eudora-J

Comment 3

18 years ago
Reassign to tonyr@fbdesigns.com.
Assignee: nhotta → tonyr

Comment 4

18 years ago
Import from Outlook Express failed too.
(Assignee)

Comment 5

18 years ago
a problem on OE is other issue.  I created new bug as bug 61100.
(Assignee)

Comment 6

18 years ago
The problems of import engine (mailnews/import/src) will be fixed by bug 61100.
But I don't have Eudora-J...

Comment 7

18 years ago
YOu can get a latest free version of Eudora Pro J now below:

http://www.eudora.ne.jp/

If you choose to download the "sponsored version" which has
some ads, you get the official version free.
(Assignee)

Comment 8

18 years ago
Momoi san, thx!
I try to download
(Assignee)

Comment 9

18 years ago
My private build works fine.
tonyr, please assign to me.  I will attached the patches to bug 61100.

Comment 10

18 years ago
Here ya go.
Assignee: tonyr → m_kato
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 11

18 years ago
Does anyone test on Macintosh?

Comment 12

18 years ago
Yes. I can look at it if the patch is available.
Or if you want to know the status of Mac Eudora Import,
I can do that, too.

Updated

18 years ago
Keywords: intl
(Assignee)

Comment 13

18 years ago
check in
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

18 years ago
Tested 2000-12-18-09-Mtrunk build. I have 3 address book cards in Eudora-J. Two
cards have ASCII names and one has Japanese name. Only the one with Japanese
name got imported. I'd like to reopen this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 15

18 years ago
Sorry, my mistake. The reason that the ASCII cards didn't get imported is
because they have empty email address fields. (bug 58929).
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

18 years ago
Marked it as verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 17

18 years ago
Verified with mac 2000-12-18-08-Mtrunk build too. Can import Ja address book
cards from Mac eudora 4.3J.
(Reporter)

Comment 18

18 years ago
Oops, this is the bug for mail import. I mistook it as a bug related to address
book import.
Sorry for the confusing comments. Here is the real results:
1. In the import wizzard, the warning still occurs. It says:
"This message contains characters not found in the chosen Character Coding, The
message may be unreadable to recipient. Send it anyway or "Cancel" to choose a
different Character coding."
   But actually on this dialog, there is no OK or Cancel button. However when I
hit Return key, it can resume the import.

2. After import finishes, there is Eudora account created. In (jushin), Out
(soushin) and Trash (Gomibako) folder in addtion to some default folders are
created under this account. For the mail in the In folder, The Ja chars can be
displayed correctly. But there are following two lines added to wrap the
original mail.
<x-flowed>
</x-flowed>

3. For the mails in Out and Trash folder, the Ja characters in the subject are
displayed as question marks both in the thread pane and msg view pane. The Ja
chars in the mail body are displayed as dots.

Based on the test results above, I reopened the bug.

Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 19

18 years ago
Created attachment 20908 [details]
The mail in the In (jushin) folder
(Reporter)

Comment 20

18 years ago
Created attachment 20909 [details]
The mail in the Out (soushin) folder.

Updated

18 years ago
Keywords: nsbeta1
(Assignee)

Comment 21

18 years ago
ji, why reopen??

Your comment is other bug.  You should open new bug, not reopen.
So I re-mark as FIXED.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 22

18 years ago
Kato-san, please see my comments at 2000-12-18 15:49 and two screenshots 
following that. Importing MAIL from Eudora-J is not working correctly yet.
(Assignee)

Comment 23

18 years ago
Ji,
mailbox issue was fixed.  So I hope that it opens as other bug that you say. 
(Reporter)

Comment 24

18 years ago
All right. Bug 64117 was filed for the extra line problem in In mailbox. And 
Bug 64119 was filed for the Ja char display problem in Out and Trash mailbox.

Comment 25

18 years ago
Re-assign to ji for verification.
It seems that the main problem has been fixed and
what remains has been filed in another bug.
QA Contact: momoi → ji
(Reporter)

Comment 26

18 years ago
Marked it as verified, since the original problem reported in this bug has been
fixed and the new problem is filed in bug 64119.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.