Closed Bug 589051 Opened 9 years ago Closed 2 years ago

Update available notification appears in foreground, but without focus

Categories

(Toolkit :: Application Update, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 893505

People

(Reporter: mike001, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/533.16 (KHTML, like Gecko) Version/5.0 Safari/533.16
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.7) Gecko/20100713 Thunderbird/3.1.1

When TB checks for available updates, the "Update available" window appears in the foreground (when TB is in background), and the window does not have focus.

Reproducible: Always

Steps to Reproduce:
1. Configure Thunderbird to "Automatically check for updates", and when updates are found, "Ask me what to do".
2. Wait until a newer version is available, keeping TB in background.
3.
Actual Results:  
The window appears in the foreground, and does not have focus.

Expected Results:  
The window would appear in the background, and the TB Dock icon should "bounce" (more than once).  When TB is brought to the foreground, the "Update available" window should be the topmost window, and should have focus.
Mike is this also the case in Firefox (I use Help -> check for updates way to often) ?
I was wrong; it doesn't always happen.  I just got a notification this morning with what I THINK was the same environment: Browser in foreground, TB in background; notification window did not come to foreground.  Will try to determine what other environmental factors may be involved.
OS: Mac OS X → Windows 7
Did it this time w/FF.  At the time, display was "sleeping", but system was active ("never sleep when plugged in").  Foreground app was Eudora; the notification window was not _completely_ in the foreground -- it was one window behind the foreground window, but still "in front of" other Eudora windows.
Component: General → Application Update
Product: Thunderbird → Toolkit
QA Contact: general → application.update
This should be fixed by the new doorhanger notification implemented in bug 893505
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893505
You need to log in before you can comment on or make changes to this bug.