Bookmark folder shows up as tiny square instead of displaying (Empty) after deleting items

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: shenjoku, Unassigned)

Tracking

3.6 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

There is a strange UI glitch that happens after deleting items from a bookmark folder using the right-click menu.

The only way I have found to make the glitch go away and the (Empty) text to appear as it should, is to restart Firefox.

I have only tested this on my home machine, which is using Windows7 x64, so I cannot confirm or deny that this will happen on other platforms yet.

Reproducible: Always

Steps to Reproduce:
1. Open the organize bookmarks menu using ctrl+shift+B and add a new folder to the bookmarks menu.
2. After the folder has been created, bookmark two different web pages and store them inside the newly created folder.
3. Open the bookmark menu in the top toolbar (by clicking on Bookmarks or using Alt+b) then mouse over the folder and delete the items in the folder one at a time using the mouse right-click menu.
4. After deleting the last item, you will see the popup window that used to be displaying the items have some weird text over it. This text is whatever part of the right-click menu was over the popup last.
5. Mouse away from the folder then back over it and you will see a tiny box appear instead of the usual popup that should be displaying (Empty) since there are no more items in the folder.
Actual Results:  
The opened popup window got messed up showing what used to be on top of it in the right-click menu. Then after moving away and mousing over the same folder again, the popup shows up as a tiny box that you can barely see.

Expected Results:  
After deleting the item it is supposed to display a single line that says (Empty)
(Reporter)

Comment 1

8 years ago
I have attached an image that shows what the broken popup looks like, which is inside of the red square.
I now this is filed already but cannot find the Bug# right now.
Whiteboard: dupeme
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> I now this is filed already but cannot find the Bug# right now.

I tried searching a for a while and couldn't find anything related so I wasn't sure.

Updated

8 years ago
Version: unspecified → 3.6 Branch
let's call it WFM then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.