Add-ons manager cannot restart xulrunner-based apps because Application is undefined

VERIFIED FIXED in mozilla2.0b7

Status

()

VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: glazou, Assigned: mossop)

Tracking

Trunk
mozilla2.0b7
Points:
---
Bug Flags:
in-testsuite -
in-litmus +

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [good first bug])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Following checkin for bug 567127, I rebuilt BlueGriffon, my own xulrunner-based app and tried the new Install Add-on UI. It works fine BUT is unable to restart my app because |Application| is undefined in extensions.js line 361.
(Reporter)

Comment 1

8 years ago
Added a workaround to https://developer.mozilla.org/en/XULRunner_tips
Maybe this is enough and this bug is a WONTFIX. Blair, you decide.
(Assignee)

Comment 2

8 years ago
THe restart messages are pretty basic functionality and should work everywhere. I guess we'll just need to stop using the FUEL wrapper for it.
blocking2.0: --- → betaN+
Depends on: 567127
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> THe restart messages are pretty basic functionality and should work everywhere.
> I guess we'll just need to stop using the FUEL wrapper for it.

Not sure. Forcing to use the workaround I documented is a good way of
centralizing this feature inside the Application "helper". That way, making
it evolve later is easier, including for xulrunner-based apps.
Just my 2 eurocents.
Not related to bug 567127 - this is an issue anywhere the addons manager prompts to restart.
No longer depends on: 567127
(Assignee)

Updated

8 years ago
Whiteboard: [good first bug]
(Assignee)

Comment 5

8 years ago
Created attachment 474302 [details] [diff] [review]
patch rev 1
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #474302 - Flags: review?(bmcbride)
Comment on attachment 474302 [details] [diff] [review]
patch rev 1

>+        return true;

Nit: Not needed.
Attachment #474302 - Flags: review?(bmcbride) → review+
(Assignee)

Comment 7

8 years ago
landed: http://hg.mozilla.org/mozilla-central/rev/6e12dfb03f56

Needs manual testing that restarts still work.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite-
Flags: in-litmus?
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b6
Daniel, can you please verify the fix with a latest version of XulRunner which has this fix included? Thanks.

Dave, how should a manual test look like? We only cover Firefox in our tests on Litmus.
(Assignee)

Comment 9

8 years ago
(In reply to comment #8)
> Daniel, can you please verify the fix with a latest version of XulRunner which
> has this fix included? Thanks.
> 
> Dave, how should a manual test look like? We only cover Firefox in our tests on
> Litmus.

The only way to really verify that this works in other applications would be to try it out in other applications. That isn't something we've traditionally done for other fixes though.
(Reporter)

Comment 10

8 years ago
(In reply to comment #8)
> Daniel, can you please verify the fix with a latest version of XulRunner which
> has this fix included? Thanks.

Will test today. Thanks.
(Reporter)

Comment 11

8 years ago
(In reply to comment #8)
> Daniel, can you please verify the fix with a latest version of XulRunner which
> has this fix included? Thanks.

Just rebuilt after a hg pull -u...
The result is... "cannot tell" because of bug 591801 :-(
Sorry but the extension manager is totally horked for me because of that one.

But reading the code, that should be ok.
I can confirm that this bug is fixed in Instantbird.

(We are also annoyed by bug 591801. We worked around it temporarily by doing a partial local backout of the patch from bug 562797.)
Thanks Florian! Given that information we can set move the status to verified fixed. I will still have to think about the requested manual test...
Status: RESOLVED → VERIFIED
On Litmus we do not cover any other application as our supported ones. But, on Ubuntu Firefox is built on top of XULrunner, which means that our various existing tests should cover this specific issue. Dave, if you think it's not the case, the request should be declined.
Flags: in-litmus? → in-litmus+
OS: Mac OS X → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.