Closed Bug 589134 Opened 11 years ago Closed 11 years ago

In a HTML context, getElementsByTagName does not match all SVG tags

Categories

(Core :: SVG, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 499656

People

(Reporter: Jeremie, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100819 Minefield/4.0b5pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100819 Minefield/4.0b5pre

When you try to use document.getElementsByTagName in an HTML document to match some SVG elements, it fails to mach some of them. If you do the same inside a SVG Document, there are no problems, all elements can be matched.

Reproducible: Always

Steps to Reproduce:
1. Open the joined HTML test case, elements marked with a 0 are not matched 
2. Open the joined SVG test case, all elements are matched

Actual Results:  
You can not select some SVG elements through getElementsByTagName inside a HTML document

Expected Results:  
You should always be able to select SVG elements through getElementsByTagName whatever the document type (HTML or SVG)
Attached file HTML Test case
The elements marked with 0 are not matched.
The elements marked with 1 are matched
Attached image SVG Test case
This is a duplicate of the bug on implementing the HTML5 behavior for getElementsByTagName (where the case-folding happens during matching, not at call-time).
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499656
You need to log in before you can comment on or make changes to this bug.