If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Omnijar warning: "cannot load binary components..."

RESOLVED FIXED in mozilla2.0b7

Status

()

Core
Build Config
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: ddahl, Assigned: mwu)

Tracking

Trunk
mozilla2.0b7
x86
All
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

7 years ago
today's build is saying this:

Warning: Cannot load binary components from the omnijar.
Source File: C:\Users\ddahl\bin\firefox\omni.jar:components/components.manifest
Line: 107

Mozilla/5.0 (Windows NT 6.1; rv:2.0b5pre) Gecko/20100820 Minefield/4.0b5pre
(Assignee)

Comment 1

7 years ago
It's a relatively harmless warning. The packaging for omnijar generates another set of manifests to point to binary components so they do end up being loaded outside of the omnijar. Should get rid of this warning one way or another though.

Updated

7 years ago
Duplicate of this bug: 589087

Comment 3

7 years ago
Wait, doesn't it remove the directive from the in-omnijar manifests? It should!
Assignee: nobody → mwu
blocking2.0: --- → final+
(Assignee)

Updated

7 years ago
Summary: Omnijar error: "cannot load binary components..." → Omnijar warning: "cannot load binary components..."
(Assignee)

Comment 4

7 years ago
Created attachment 468416 [details] [diff] [review]
Comment out binary-component entries
Attachment #468416 - Flags: review?(benjamin)

Updated

7 years ago
Attachment #468416 - Flags: review?(benjamin) → review+
(Assignee)

Comment 5

7 years ago
Created attachment 469702 [details] [diff] [review]
hg patch ready patch
Attachment #468416 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/9f8fc8a50525
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b5
This patch broke the Windows builds.  Apparently it was never tested on try.  Please do make sure to test the new version of the patch on try server before marking it as checkin-needed.

Sample log:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1282921760.1282921760.10529.gz

Backout:
http://hg.mozilla.org/mozilla-central/rev/ccd462cc196d
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 8

7 years ago
Created attachment 470669 [details] [diff] [review]
hg patch ready patch, v2

This one is uglier but works on windows.
Attachment #469702 - Attachment is obsolete: true
(Assignee)

Comment 9

7 years ago
Passed try.
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/ea9e5837cf6d
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: mozilla2.0b5 → mozilla2.0b6
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.