1Password Immediate crash submitting forms [@ libosxform_xpcom.dylib@0x550d ] [@ libosxform_xpcom.dylib@0x7b76 ] [@ libosxform_xpcom.dylib.0x54f5 ] [@ libosxform_xpcom.dylib.0x51b5 ]

RESOLVED FIXED

Status

()

defect
--
critical
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: neilio, Unassigned)

Tracking

Trunk
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [probably needs blocklisting][fixed by author][hardblocker])

Reporter

Description

9 years ago
In the latest Mac OS X trunk nightly (20100819), submitting any form immediately crashes Minefield. I tested this with a clean profile and reproduced the crash.

Crash log:
http://crash-stats.mozilla.com/report/index/bp-20b1e5ec-d738-44fb-8156-33cc42100820

Updated

9 years ago
Severity: normal → critical
Summary: Immediate crash submitting forms (libosxform_xpcom.dylib@0x550d] → Immediate crash submitting forms [@ libosxform_xpcom.dylib@0x550d ]
We have tests for form submission, so if it really was broken in general, we'd know as soon as the breaking change landed :)

libosxform_xpcom is the 1Password extension, so likely not a problem with Firefox code. Try updating it, or reporting this to the extension author? Finding a regression range to find the Firefox change that busted it could be useful too, but given 1password's history it's likely that they're just relying on something they shouldn't be relying on.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID

Updated

9 years ago
Component: XPCOM → Extension Compatibility
Product: Core → Firefox
Summary: Immediate crash submitting forms [@ libosxform_xpcom.dylib@0x550d ] → 1Password Immediate crash submitting forms [@ libosxform_xpcom.dylib@0x550d ]
Reporter

Comment 2

9 years ago
Thanks for the clarification Gavin - I pushed this back to the 1Password developers.
Adding the stack that comes up on Mac so this gets picked up in crash stats.
Summary: 1Password Immediate crash submitting forms [@ libosxform_xpcom.dylib@0x550d ] → 1Password Immediate crash submitting forms [@ libosxform_xpcom.dylib@0x550d ] [@ libosxform_xpcom.dylib@0x7b76 ]

Comment 4

9 years ago
the combined set of stack signatures makes this the #1 crash on beta4 in early data gathering.
Summary: 1Password Immediate crash submitting forms [@ libosxform_xpcom.dylib@0x550d ] [@ libosxform_xpcom.dylib@0x7b76 ] → 1Password Immediate crash submitting forms [@ libosxform_xpcom.dylib@0x550d ] [@ libosxform_xpcom.dylib@0x7b76 ] [@ libosxform_xpcom.dylib.0x54f5 ]

Updated

9 years ago
Summary: 1Password Immediate crash submitting forms [@ libosxform_xpcom.dylib@0x550d ] [@ libosxform_xpcom.dylib@0x7b76 ] [@ libosxform_xpcom.dylib.0x54f5 ] → 1Password Immediate crash submitting forms [@ libosxform_xpcom.dylib@0x550d ] [@ libosxform_xpcom.dylib@0x7b76 ] [@ libosxform_xpcom.dylib.0x54f5 ] [@ libosxform_xpcom.dylib.0x51b5 ]

Comment 5

9 years ago
any, reponse back from  1Password developers.  can we get them cc'ed on this bug to track status of a fix?   lets leave this extension compat bug open until we know a fix is in place.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
1password is not listed on AMO, so I don't have any information on the developers. This is the homepage for the application and add-on: http://agilewebsolutions.com/products/1Password.
I downloaded the Mac package and found the add-on code. As it often happens with add-ons listed elsewhere, there's a lot wrong with it, like having a maxVersion of 4.*

Comment 7

9 years ago
Unfortunately, the current version of 1Password 3 is not compatible with Firefox 4 betas.

We had quite a bit of trouble getting it to compile with the new Gecko SDK and there are still a few unresolved issues that we are working on.

Roustem
Co-author of 1Password
Roustem: If it is not compatible with FF 4 can you please change the maxVersion in the extension to match that fact? Many of our beta users are hitting this crash.
QA Contact: xpcom → extension.compatibility

Comment 9

9 years ago
Marcia, this is a great idea! I am not sure what was I thinking before, that would save us all a lot of trouble (I guess FF4b1 was working fine and then we left the extension enabled for all v4 builds).

I updated the compatibility settings and hope to get the new version published soon.
Roustem: It would be great to get this published before we ship Beta 5. Can you please update this bug when you have pushed the new version?

(In reply to comment #9)
> Marcia, this is a great idea! I am not sure what was I thinking before, that
> would save us all a lot of trouble (I guess FF4b1 was working fine and then we
> left the extension enabled for all v4 builds).
> 
> I updated the compatibility settings and hope to get the new version published
> soon.

Comment 11

9 years ago
(In reply to comment #10)
> Roustem: It would be great to get this published before we ship Beta 5. Can you
> please update this bug when you have pushed the new version?

BETA5 addresses the Firefox 4b4 crash and BETA6 addresses a FF4 nightly crash.

BETA5: http://agilewebsolutions.com/products/1Password/versions/betas#v30731
BETA6: http://agilewebsolutions.com/products/1Password/versions/betas#v30735

(I'm not the developer, just a user that received BETA5 which fixed the crash for me.)
Duplicate of this bug: 594440
blocking final for crashes to disappear or blacklist entry.
blocking2.0: --- → final+
Whiteboard: [probably needs blocklisting]
blocking2.0: final+ → betaN+

Comment 14

9 years ago
The latest version of the 1Password add-on works fine in Firefox 4 (both with login forms and basic auth). The Add-on Manager lists it as version 3.5.4beta 3 (and I know an earlier release fixed the form submission problems...)

Comment 15

9 years ago
I don't know what the policy is about blocklisting and whether we're still seeing these crashes, but it seems like we may be able to close this given that 1password has fixed this with an update on their end. I'm hesitant to close this myself not knowing if there's some sort of blocklisting required still.

This is on the hardblocker list, though, so we should try to pick this off one way or another soon.
Whiteboard: [probably needs blocklisting] → [probably needs blocklisting][fixed by author]

Comment 16

9 years ago
looks like  volume for all libosxform_xpcom.dylib crashes is about 0-4 per day and its been that way for the last several weeks..

Comment 17

9 years ago
I'll make the leap and say this is fixed then.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Whiteboard: [probably needs blocklisting][fixed by author] → [probably needs blocklisting][fixed by author][hardblocker]

Comment 18

9 years ago
Yes, we fixed it a few weeks ago. Sorry for the trouble!

Roustem Karimov
Co-author of 1Password
You need to log in before you can comment on or make changes to this bug.