Note: There are a few cases of duplicates in user autocompletion which are being worked on.

[D2D] <strong> and <b> are cumulative with Arial

RESOLVED INVALID

Status

()

Core
Graphics
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Loïc Yhuel, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100820 Minefield/4.0b5pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100820 Minefield/4.0b5pre

If D2D is enabled, if some text is under both <strong> and <b>, it is bolder.
It seems to only happen with Arial.

Reproducible: Always

Steps to Reproduce:
Display the attached HTML testcase
Actual Results:  
First line of text is bolder than second line.

Expected Results:  
The two lines have the same font weight, like when D2D is disabled

Extracted from :
http://www.pcinpact.com/actu/news_multi/58871.htm (news title "PCi Labs : On a tenté d'overclocker le portable M11x d'Alienware")

IE9 PP4 has the same bug on the HTML testcase, but not on the whole page.
(Reporter)

Comment 1

7 years ago
Created attachment 467981 [details]
HTML testcase
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
This is correct behavior. Arial is a font family with 4 weights. In our previous implementations we did not have the ability to handle these families correctly. Since DirectWrite we do. We've noticed there's websites doing this incorrectly, it was discussed and we decided to evangelize the correct usage, rather than continue to support the incorrect behavior.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

7 years ago
IE9 has a different behavior, as it's like Firefox with DirectWrite on the testcase, but not on PCInpact site.
So unless this is an IE9 bug, they perhaps have implemented some compatibility to avoid breaking sites.

It would mean we could have 3 different behaviors :
1) Firefox without DirectWrite, Chrome, IE8
2) Firefox with DirectWrite
3) IE9, sometimes like 1), sometimes like 2)
(In reply to comment #3)
> IE9 has a different behavior, as it's like Firefox with DirectWrite on the
> testcase, but not on PCInpact site.
> So unless this is an IE9 bug, they perhaps have implemented some compatibility
> to avoid breaking sites.
> 
> It would mean we could have 3 different behaviors :
> 1) Firefox without DirectWrite, Chrome, IE8
> 2) Firefox with DirectWrite
> 3) IE9, sometimes like 1), sometimes like 2)

Difficult to say, there was e-mail conversation with them about this, and they believed in evangelizing the correct solution too. Since <b><strong> for the Arial family would correctly lead to the standard Arial Black face being used. John Daggett knows this kind of stuff better than I do though.

Comment 5

7 years ago
Your testcase relies on the default style for the <b> element being 'bold'.  Firefox defines both as 'bolder', hence <strong><b>blah</b></strong> should be bolder than <strong>blah</strong> if a font family with black face is used.

My guess the difference between FF4 and IE9 is not the rendering but the default style sheet used.
(Reporter)

Comment 6

7 years ago
(In reply to comment #5)
> Your testcase relies on the default style for the <b> element being 'bold'. 
> Firefox defines both as 'bolder', hence <strong><b>blah</b></strong> should be
> bolder than <strong>blah</strong> if a font family with black face is used.
> 
> My guess the difference between FF4 and IE9 is not the rendering but the
> default style sheet used.

Strange as <strong><strong>blah</strong></strong> like <strong><b>blah</b></strong>, but <b><b>blah</b></b> is not.
So perhaps <strong> is defined as bolder, and <b> as bold.

Chrome has the same logic : its calculated style is "bolder", but it's displayed like bold for the same reason FF4 does without DirectWrite.

In fact the PCInpact page I was testing on IE9 is not exactly the same (it depends if you are logged in or not), it didn't have the <b>.
So with exactly the same page, IE9 and FF4 DirectWrite have the same rendering.

Comment 7

7 years ago
May I ask if the weight name has to be Bold for bolds to show?

Presently I am having trouble with http://jackyan.tumblr.com, where text in <strong> is coming up as the regular weight.

There is no Doctype specified on the page, but I note that Firefox 3 never had this issue.

Comment 8

7 years ago
Created attachment 513270 [details]
Bolds fail to show in 4 Beta 12

No bolding appears despite <strong> tags in 4 Beta 12.

Comment 9

7 years ago
Created attachment 513272 [details]
Comparison: text bolded in Firefox 3·6·13

For comparison, a screen shot of the same page as displayed by Firefox 3·6·13. The bolds are there, surrounded by <strong> tags.
You need to log in before you can comment on or make changes to this bug.