Closed Bug 589470 Opened 14 years ago Closed 14 years ago

tab dragged out of browser on first monitor to second monitor incorrectly opens on 1st

Categories

(Firefox :: General, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 465186

People

(Reporter: donadryane, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

If you are running with dual monitors, it is useful to drag a tab out of a browser on one monitor, and put it on the other monitor.  Unfortunately if you try to do it, firefox malfunctions and opens the new browser window on the same monitor as the old browser window.  The new browser window then has to be dragged to the second monitor.

This seems caused by a very simple failure to consider the 2 monitor setup.

Reproducible: Always

Steps to Reproduce:
0.  Run firefox on computer with two monitors.
1.  Open two tabs in browser on monitor 1.
2.  Drag one tab to monitor 2.
3.  Watch new browser window open on monitor 1.
Actual Results:  
2nd browser opens on monitor 1

Expected Results:  
2nd browser opens on monitor 2

Pulling a tab out of the browser and pulling it to a second monitor is a very common practical thing to do when using a dual monitor setup.  Firefox fails to do so correctly.
Thanks for the report! It's a known problem though.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.