(ietestcenter) HTML5 Media Elements 1/23: 'buffered' returns a TimeRanges object.

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: darxus-mozillabug, Assigned: cpearce)

Tracking

({html5})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 beta5+)

Details

()

Attachments

(1 attachment, 1 obsolete attachment)

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre

Fails test.

Reproducible: Always
Blocks: ietestcenter
Version: unspecified → Trunk
We need to s/HTMLTimeRanges/TimeRanges/q
Blocks: 462957
Status: UNCONFIRMED → NEW
Component: General → Video/Audio
Ever confirmed: true
Keywords: html5
OS: Linux → All
QA Contact: general → video.audio
Hardware: x86_64 → All
Thanks for filing all these ietestcenter bugs Darxus, much appreciated.

(In reply to comment #1)
> We need to s/HTMLTimeRanges/TimeRanges/q

 Ms2ger is correct, we've named our time ranges object HTMLTimeRanges, but the spec calls the interface TimeRanges:
http://www.whatwg.org/specs/web-apps/current-work/multipage/video.html#timeranges

We should fix this before we ship buffered in Firefox 4, it's a pretty easy fix.
blocking2.0: --- → ?
Chris: You're welcome, and thanks for the response.  I've been waiting to see how they were received to continue.
Looks like we also call MediaError HTMLMediaError. That should change too.
Rename HTMLTimeRanges to TimeRanges, HTMLMediaError to MediaError. We pass the ietestcenter test with this patch.
Assignee: nobody → chris
Attachment #468532 - Flags: review?(roc)
Attachment #468532 - Flags: approval2.0?
nsIMediaError and nsITimeRanges should be nsIDOMMediaError and nsIDOMTimeRanges respectively. Other than that, this is good.
Posted patch Patch v2Splinter Review
With nsIDOM{MediaError,TimeRanges} instead of nsI{MediaError,TimeRanges}.
Attachment #468532 - Attachment is obsolete: true
Attachment #468575 - Flags: review?(roc)
Attachment #468575 - Flags: approval2.0?
Attachment #468532 - Flags: review?(roc)
Attachment #468532 - Flags: approval2.0?
Attachment #468575 - Flags: review?(roc)
Attachment #468575 - Flags: review+
Attachment #468575 - Flags: approval2.0?
Attachment #468575 - Flags: approval2.0+
blocking2.0: ? → beta5+
http://hg.mozilla.org/mozilla-central/rev/37f61e9d618a
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.