Want a splitter that only exists to collapse, not to resize

RESOLVED FIXED

Status

()

Toolkit
Themes
--
enhancement
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
In bug 585601 we discovered that the following XUL:
<splitter disabled="true" collapse="after"><grippy/></splitter>
creates a splitter that can be collapsed but not resized.

However the problem is that the resize cursor still appears on the splitter.

If disabling splitters makes sense for any other reason, then they obviously would not want a resize cursor either.
(Assignee)

Comment 1

7 years ago
Created attachment 468150 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #468150 - Flags: review?(dao)

Updated

7 years ago
Attachment #468150 - Flags: review?(dao) → review+
(Assignee)

Comment 2

7 years ago
Comment on attachment 468150 [details] [diff] [review]
Proposed patch

Seeking approval for this trivial theme enhancement.
Attachment #468150 - Flags: approval2.0?
Attachment #468150 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 3

7 years ago
Pushed changeset 345438665f24 to mozilla-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.