Put all preshints (at least for HTML, independent of document type) in the author level

RESOLVED FIXED in mozilla2.0b10

Status

()

Core
CSS Parsing and Computation
P2
normal
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Darxus, Assigned: bz)

Tracking

(Blocks: 1 bug, {html5})

Trunk
mozilla2.0b10
x86_64
Linux
html5
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre
Build Identifier: 

Fails test.

Reproducible: Always
(Reporter)

Updated

8 years ago
Blocks: 554013
Version: unspecified → Trunk
This test is either assuming that CSS2.1 section 6.4.4 includes XHTML when it says "HTML" (I see no basis for this assumption) or that default link styling is in the UA level in the cascade.  In Gecko it's in the user level.

So, unless the assumption about CSS2.1 is correct for some reason I missed, the test is broken and we need to get the IE folks to fix it.
Component: General → Style System (CSS)
QA Contact: general → style-system
Ok, the HTML5 spec does have verbiage about this.  http://www.whatwg.org/specs/web-apps/current-work/complete/rendering.html#the-css-user-agent-style-sheet-and-presentational-hints second paragraph of the introduction, in particular.

Furthermore, SVG says that its preshints should go in the author level too (SVG 1.1, section 6.4, paragraph starting "For user agents that support CSS, the presentation attributes must be translated".  We don't do that currently.

David, how would you feel about just putting all preshints in the author level?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: (ietestcenter) HTML5 XHTML5 2/9: Test for link="yellow" on body → Put all preshints (at least for HTML, independent of document type) in the author level
Keywords: html5
Assignee: nobody → bzbarsky
Priority: -- → P2
Yes, I think we should change this.

The CSS spec was never really explicit here; the XHTML WG clearly wanted the XML-like option, but we should make it HTML-like.
Created attachment 484226 [details] [diff] [review]
part 1.  Get rid of the non-HTML preshint level.
Created attachment 484227 [details] [diff] [review]
part 2.  Rename the HTML preshint level to just the preshint level, since it's the only preshint level now.
Whiteboard: [need review]
Attachment #484226 - Flags: review?(dbaron)
Attachment #484227 - Flags: review?(dbaron)
dbaron, do you think we should try to get this in for 2.0?
Comment on attachment 484226 [details] [diff] [review]
part 1.  Get rid of the non-HTML preshint level.

Seems like this comment should stay:
>-  //Enable/Disable entire author style level (Doc & PresHint levels)

r=dbaron
Attachment #484226 - Flags: review?(dbaron) → review+
Comment on attachment 484227 [details] [diff] [review]
part 2.  Rename the HTML preshint level to just the preshint level, since it's the only preshint level now.

r=dbaron
Attachment #484227 - Flags: review?(dbaron) → review+
> Seems like this comment should stay:

Agreed and reinstated.
Created attachment 493894 [details] [diff] [review]
roll-up for approval

This is fairly safe and fixes some reasonably prominent test failures.
Attachment #493894 - Flags: approval2.0?
Whiteboard: [need review] → [need approval]
Attachment #493894 - Flags: approval2.0? → approval2.0+
Whiteboard: [need approval] → [need landing]
Pushed:
  http://hg.mozilla.org/mozilla-central/rev/1133df9783f4
  http://hg.mozilla.org/mozilla-central/rev/65dfc25b1cae
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [need landing]
Target Milestone: --- → mozilla2.0b10

Updated

7 years ago
Duplicate of this bug: 388071
You need to log in before you can comment on or make changes to this bug.