Note: There are a few cases of duplicates in user autocompletion which are being worked on.

(ietestcenter) HTML5 Foreign Content 2/24: Test passes if 'FillerText' is rendered as italic.

RESOLVED WONTFIX

Status

Tech Evangelism
Desktop
RESOLVED WONTFIX
7 years ago
11 months ago

People

(Reporter: Darxus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre
Build Identifier: 

Fails test.

Reproducible: Always
(Reporter)

Updated

7 years ago
Blocks: 554013
Version: unspecified → Trunk

Comment 1

7 years ago
This test is bogus.  In particular, the SVG spec is very clear that the text should be laid out in such a way that the baseline of the text is at the y position of the <text> element, and since the "y" attribute is not specified, the y position defaults to 0.  Thus all the text is above the top of the <svg> bounding box and is clipped out.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
Product: Core → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified

Comment 2

7 years ago
And it's clipped out because SVG 1.1 section 14.3.3 says that the default value of 'overflow' for <svg> is 'hidden'.
<http://lists.w3.org/Archives/Public/public-html-testsuite/2010Jun/0052.html>

Comment 4

7 years ago
It might be good to also keep the original tests but change the pass condition to the content not being visible (which IE9 would therefore fail).

Comment 5

7 years ago
http://blogs.msdn.com/b/ie/archive/2011/02/10/acting-on-feedback-ie9-release-candidate-available-for-download.aspx#10127751

Patrick Dengler [MSFT] 10 Feb 2011 3:30 PM

> 589638 and 589639 states that the test is 'bogus' because the default in SVG 
> for overflow is hidden.  We discussed this in the working group and since the 
> default in CSS for HTML is overflow:visible, and since this is an HTML page 
> (and not SVG or XHTML), the default should be visible, these seem to be valid.


http://www.w3.org/TR/SVG/masking.html#OverflowProperty

> The initial value for ‘overflow’ as defined in [CSS2-overflow] is 'visible', 
> and this applies also to the root ‘svg’ element; however, for child elements 
> of an SVG document, SVG's user agent style sheet overrides this initial value 
> and sets the ‘overflow’ property on elements that establish new viewports 
> (e.g., ‘svg’ elements), ‘pattern’ elements and ‘marker’ elements to the value 
> 'hidden'.


If I'm reading that right (probably not), that <svg> element should have "overflow: visible" on it.

Comment 6

7 years ago
SVG's user agent style sheet is applied to all documents, though, not just SVG documents...  That informative text is not consistent with normative text elsewhere, basically, as far as I can see.

Comment 7

7 years ago
In particular, the normative text at http://www.w3.org/TR/SVG/styling.html#UAStyleSheet which clearly says that that rule applies to all <svg> elements, not just those in an SVG document.

Comment 8

3 years ago
Not sure why this is a tech evangelism issue and who/what actions should be taken on that?
It seems more a discussion in between people involved in creating test suites.
Assignee: english-us → nobody
Component: English US → Desktop

Comment 9

3 years ago
This isn't a test suite; it's an IE marketing site...

Updated

3 years ago
See Also: → bug 620653
Edge now renders this exactly the same as Firefox and Chrome. Given that, let's close as WONTFIX (to mean something like: not worth the effort at this point). 

Microsoft isn't marketing IE anymore these days.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.