Range surroundContents not implemented

VERIFIED DUPLICATE of bug 58974

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED DUPLICATE of bug 58974
18 years ago
5 years ago

People

(Reporter: Dylan Schiemann, Assigned: anthonyd)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
BuildID:    20001031

surroundContents DOM 2 Range method not yet implemented

Reproducible: Always
Steps to Reproduce:
1. attempt to surroundContents of a Range returns not implemented error

Actual Results:  NS_ERROR_NOT_IMPLEMENTED

testcase to follow

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 58974 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Component: DOM Level 2 → DOM Traversal-Range

Comment 3

17 years ago
Created attachment 27458 [details]
Patch for Range functionality

Comment 4

17 years ago
I am attaching a JavaScript "Patch" that can be used as a work around for the 
range object.  This patch adds support for the following:
    Range.innerHTML - read only
    Range.extractContents - as per W3C specs
    Range.cloneContents - as per W3C specs
    Range.insertNode - as per W3C specs
    Range.surroundContents - as per W3C specs
    Range.deleteContents - as per W3C specs - fixes buggy support from Mozilla
    Range.jmyCompareNode - extends Mozilla's compareNode to include
                           the following 2 constants
    Range.NODE_BEFORE_AND_INSIDE = -1;
    Range.NODE_INSIDE_AND_AFTER = -2;

I would like a C++ programmer to implement these in C if possible.

Jeff Yates
Component: DOM: Traversal-Range → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.