Doorhanger causes all non-doorhanger input to be swallowed

VERIFIED WORKSFORME

Status

()

Firefox
General
--
critical
VERIFIED WORKSFORME
7 years ago
5 years ago

People

(Reporter: jdm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [doorhanger])

(Reporter)

Description

7 years ago
STR:
1. hit up a site that brings up a geolocation notification
2. attempt to focus any other window (via mouse or alt+tab) or use a keyboard shortcut for anything

Expected:
Other window focuses.

Actual:
Nothing happens.  It is impossible to do anything else while a notification is showing in Firefox.

I set a breakpoint in the geolocation code that runs when sharing your location and completely locked up my system, as I couldn't get back to the gdb window because the doorhanger was still showing in Firefox.

I'm running m-c tip, Fedora 12 and GNOME 2.28.2.
(Reporter)

Comment 1

7 years ago
Sorry, I lied about the actual results.  When clicking outside of firefox the notification disappears, which obviously accounts for why I couldn't leave firefox when it was paused for debugging.

Comment 2

7 years ago
Is this just bug 392580, or are you referring to something else?
(Reporter)

Comment 3

7 years ago
Bug 392580 sounds quite similar, but Firefox shortcuts (such as Ctl+J) work.
Whiteboard: [doorhanger]
(Reporter)

Comment 4

7 years ago
With the advent of bug 545429 landing, this is no longer an issue.  I am thrilled!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Cannot reproduce this bug with Firefox 4.0b12pre 20110218 -- marking verified.
Status: RESOLVED → VERIFIED
this is still broken in Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0 Iceweasel/17.0.1
You need to log in before you can comment on or make changes to this bug.