Closed Bug 590206 Opened 9 years ago Closed 9 years ago

Make the site identity UI display something sensible for about: and chrome: uris

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla2.0b8
Tracking Status
blocking2.0 --- final+

People

(Reporter: aaronmt, Assigned: mossop)

References

Details

Attachments

(4 files)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b5pre) Gecko/20100824 Minefield/4.0b5pre

In the build above, when I open the Add-ons Manager, I am presented with a green coloured puzzle piece with a grey background. 

When I move around the menu items and land back at Get Add-ons, the Favicon changes to a similar image but with a blue background.

Any further menu selections will not alter the currently present favicon (i.e, it will remain with a blue background)

STR: 
1. Open the Add-ons Manager
2. See green puzzle piece and grey background Favicon
3. Select Extensions/ and then Select Get Add-ons
4. See Favicon swap to blue background
Woops, looks like this is happening because of Blue Larry (i.e., Open in it's own frame to see it)
Yeah I thought there was something on file for this already, but this isn't ideal and we should probably fix it.
Summary: Add-ons manager favicon swaps background colour on switch to Get Add-ons → Site identity indicator changes colour when viewing the discovery pane in the add-ons manager
blocking2.0: --- → final+
Whiteboard: [good first bug]
Hm, [good first bug]?

Isn't this really a core bug? onSecurityChange is just doing what it's being told here.
(In reply to comment #3)
> Hm, [good first bug]?

I think all we want is for the identity bar to display something else for the case where chrome: or privileged about: is loaded in the browser. I think that should be fairly straightforward to do.

> Isn't this really a core bug? onSecurityChange is just doing what it's being
> told here.

Maybe yes, there's been a bit of a tradition of having the frontend bits of extension handling still in this component, I'm not really concerned where it is filed though.
This slipped through my fingers.

Quick proposal: For about: and chrome: uris we will create a clever string to say that the webpage is actually a part of Firefox and is safe to use. That will be the tooltip for the identity button and also the only string displayed in the identity popup where the Larry icon will be replaced by the Firefox logo. Also the More Information button shall be hidden as it is totally useless for these cases.

Boriss shall come up with said string.
Assignee: nobody → dtownsend
Summary: Site identity indicator changes colour when viewing the discovery pane in the add-ons manager → Make the site identity UI display something sensible for about: and chrome: uris
(In reply to comment #5)
> This slipped through my fingers.
> 
> Quick proposal: For about: and chrome: uris we will create a clever string to
> say that the webpage is actually a part of Firefox and is safe to use. That
> will be the tooltip for the identity button and also the only string displayed
> in the identity popup where the Larry icon will be replaced by the Firefox
> logo. Also the More Information button shall be hidden as it is totally useless
> for these cases.
> 
> Boriss shall come up with said string.

String probably doesn't need to be too clever - how about just "This page is a part of Firefox and is safe to use."

Incidentally, this is a temporary problem for Firefox 4.0, as future Firefox in-content pages will have breadcrumb navigation instead of a URL bar.

The Blue Larry is a separate problem.  Could we separate the icon from the grey/blue/green background and display it on the URL bar without a background at all?  Perhaps this would signify that this isn't a site and the site identity button isn't going to be very useful.
(In reply to comment #6)
> The Blue Larry is a separate problem.  Could we separate the icon from the
> grey/blue/green background and display it on the URL bar without a background
> at all?  Perhaps this would signify that this isn't a site and the site
> identity button isn't going to be very useful.

The original mockups for the add-ons manager showed an orange site identity button so I was considering just doing that, but if we just don't make it a button at all (would that look weird) then we probably wouldn't even need strings. Might be a bit inconsistent though.
Attached image screenshot
Like so? Or are you sold on having the text at the bottom, that seems different to other examples we have
(In reply to comment #8)
> Created attachment 481066 [details]
> screenshot
> 
> Like so? Or are you sold on having the text at the bottom, that seems different
> to other examples we have

Text aligned top is fine: consistency with other notifications is the important thing here.

(In reply to comment #7)
> (In reply to comment #6)
> > The Blue Larry is a separate problem.  Could we separate the icon from the
> > grey/blue/green background and display it on the URL bar without a background
> > at all?  Perhaps this would signify that this isn't a site and the site
> > identity button isn't going to be very useful.
> 
> The original mockups for the add-ons manager showed an orange site identity
> button so I was considering just doing that, but if we just don't make it a
> button at all (would that look weird) then we probably wouldn't even need
> strings. Might be a bit inconsistent though.

Because we had assumed that URL bars would not be present on in-content pages (see bug 571970), how a URL bar should be styled hasn't been look at until now.  The priorities for such a design are:

• Unspoofable
• Feels a part of the browser rather than a part of the web
• Fits in with current visual style
• Assures user the page is safe to use

We're already using the grey, green, and blue backgrounds for favicons and certificates.  An orange background, like in the old mockups, would certainly be noticeable.  However, bright orange on a muted interface would look out of place and not match the style of the in-content page itself.  Besides, on Windows it would compete and perhaps be visually confusing with the orange Firefox menu.

Let's use a grey background - like the default favicon - but just display the word "Firefox" on it.  Then we can change the “about:” string to human language so it forms a title for the in-content page.  If the user types "about:add-ons", they see Firefox with a background, and in text they see "Add-ons Manager."  If they type about:config, they see “Firefox” with the background, and in text they'd see "Configuration."  


Well, if it's on the table, we could do something slightly better here for Firefox 4 to make it clear the page is different, unspoofable, etc.  A big orange button may not be best now that the Firefox button is big and orange on Windows,
Ignore the last paragraph above.. left over paste trash in document
Attached patch quick fix rev 1Splinter Review
Rather than going through the late strings process etc. I've opted for the simple fix here. This just gets rid of the toolbar and popup for the site identity for any chrome or about pages (except for about:blank). Also makes it so the button doesn't look clickable in those cases.
Attachment #486441 - Flags: review?(gavin.sharp)
Whiteboard: [good first bug] → [has patch][needs review gavin]
Comment on attachment 486441 [details] [diff] [review]
quick fix rev 1

>diff --git a/browser/themes/pinstripe/browser/browser.css b/browser/themes/pinstripe/browser/browser.css

>+#identity-box.chromeUI {
>+  box-shadow: none;
>+  background-image: none;
>+}

Was the goal of these rules to make the icon appear less "clickable"? I find the icons look a bit odd without the surrounding background box, I'm not sure it's worth doing.
Attachment #486441 - Flags: review?(gavin.sharp) → review+
Whiteboard: [has patch][needs review gavin] → [has patch]
Landed without the styles, we'll see how it works out: http://hg.mozilla.org/mozilla-central/rev/a0c57346cb22
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: in-testsuite+
Flags: in-litmus-
Resolution: --- → FIXED
Whiteboard: [has patch]
Target Milestone: --- → mozilla2.0b8
So far there is nothing to see.  Is a popup suppose to show up now when clicking on about: icons?
(In reply to comment #14)
> So far there is nothing to see.  Is a popup suppose to show up now when
> clicking on about: icons?

No, the identity popup should not open. 

Marking as verified fixed with builds on OS X and Linux (builds on Windows are delayed) like Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101125 Firefox/4.0b8pre ID:20101125030318
Status: RESOLVED → VERIFIED
OS: Mac OS X → All
Hardware: x86 → All
Duplicate of this bug: 432809
Depends on: 656290
Looks like about:blank was missed, I put bug 656290 for it.
I think it would be better to keep location.protocol unset instead of setting it to http in the about:blank case - https://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#4271
You need to log in before you can comment on or make changes to this bug.