CodeAlloc allocation doesn't follow no-failure contract

RESOLVED DUPLICATE of bug 559707

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 559707
7 years ago
7 years ago

People

(Reporter: vlad, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

nanojit CodeAlloc's allocator is defined to never fail, but on windows all it does is call VirtualAlloc.  VirtualAlloc can return null, which just gets passed up to the caller, which then happily tries to use it.  We should abort if we ever get NULL back there.
blocking2.0: --- → ?
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 559707

Updated

7 years ago
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.