Firefox 4b4 occasionally freezes on restart with multiple tabs (including app tabs ) open in two windows

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: msth67, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-12-15])

Attachments

(1 attachment)

19.32 KB, application/vnd.oasis.opendocument.text
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b4) Gecko/20100818 Firefox/4.0b4
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

Upon restarting Firefox 4b4 from the last session (option set to : show windows & tabs from last time) with two windows each with multiple tabs open,one also including several app tabs,the window with app tabs froze,as a result couldn't switch between open tabs,also some navigation bar buttons (bookmarks button & some custom ones as feeds and BetterPrivacy) were missing,moved back to the customization box.I had to close the windows & restart the browser,also dragging  lost buttons in the navigation bar again-on restart it all worked again,except tab order was slightly altered.

Reproducible: Didn't try

Steps to Reproduce:
1.open two windows,each with multiple tabs,one with several app tabs (a couple of custom buttons should  also be placed in the navigation bar)
2.set option to: remember windows & tabs from last time,exit Firefox
3.restart browser
Actual Results:  
Buttons were missing in the navigation bar,after dragging them back in place the window with the app tabs was frozen:impossible to switch tabs,other functions like bookmarks still worked,close button worked making possible to restart the browser.

Expected Results:  
Browser should reopen windows & tabs from last session,navigation bar layout should not change,tabs should neither freeze or shift position.

Tab candy enabled (button dragged to the navigation bar),but -apparently- not in use at the time this issue surfaced.
(Reporter)

Updated

8 years ago
Severity: major → normal
(Reporter)

Comment 1

8 years ago
 It just happened again:apparently what triggers it is having two windows each with multiple tabs  and using Tab candy at least for one of the windows:the browser gets unresponsive,once restarted in one of the windows the Tab candy button (along with some other optional buttons as well) is missing and the open tabs are frozen,also the actual tab content doesn't match the tab's favicon & description (basically,a different URL is shown).
Severity: normal → major
(Reporter)

Comment 2

8 years ago
It keeps happening when two windows are opened (each with multiple tabs),tab candy (panorama) has been used,and "remember windows & tabs" option is enabled:this time has happened even if one of the two windows was closed  before exiting Firefox,so that only one window (with its own tabs) had to be remembered at restart.
Toolbar resetting (lost customization,some add-ons buttons missing and bookmarks button moved to the right default position) also happened again.
(Reporter)

Updated

8 years ago
Whiteboard: 4b4
(Reporter)

Comment 3

8 years ago
possibly related to this : https://bugzilla.mozilla.org/show_bug.cgi?id=554279

or,at least they occasionally surface at the same time.
Summary: Firefox 4b4 freezes on restart with multiple tabs (app tabs too) open in two windows-buttons missing in the navigation bar also → Firefox 4b4 occasionally freezes on restart with multiple tabs (including app tabs ) open in two windows- buttons missing in the navigation toolbar also
Does it also happen in Safe Mode (http://support.mozilla.com/en-US/kb/Safe Mode)?
Version: unspecified → Trunk
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> Does it also happen in Safe Mode ?

I haven't tried,since it occurs randomly (in most cases,all others things being apparently equal,Firefox restarts as expected,all tabs saved from last session are OK,no modifications in the toolbar)-furthermore just exiting the session and restarting the browser always fixes the tab freeze issue,although,if toolbar resetting also happened,it still has to be customized again.
Well, Safe Mode is important. So please test and try to reproduce. If nothing like the reported issue can be seen an extension is causing these problems.
Whiteboard: 4b4 → [closeme 2010-09-15]
(Reporter)

Comment 7

8 years ago
I've tried Safe Mode,tab freezing did not happen (but then,it doesn't happen each time in normal mode either)-as for the seemingly related issue of toolbar resetting,since Safe Mode reverts everything to default,I haven't been able to observe it.
One thing about the freezing issue:seems more likely to happen in a window containing app tabs.
(Reporter)

Comment 8

8 years ago
This one is hard to catch,very random:sometimes tabs will freeze & toolbar reset on restart,other times everything will be fine and launching a new window will trigger it again-besides,apparently launching Firefox in safe mode first,then closing and restarting in normal mode,will fix (for the time being) the issue.
Just play with it for a while and re-enable extensions until the issue is back. It can be kinda hard to test but looks like there is no other way yet. There is still a chance to get it fixed in the release if it is a core issue. But first we have to sort out the extension question. Thanks for your efforts on it!
(Reporter)

Comment 10

8 years ago
I've finally traced it down to this extension: BabelFish , disabling it solves the whole issue,enabling takes it back again.It must however be noticed that worked OK in previous betas,it all started with b4,anyhow I've just sent a compatibility report.If  a list of other installed extensions is needed to check for conflicts,please let me know-thank you.
Thanks for tracking down this issue! Beside the compatibility report I would advice you to also send an email directly to the author of that extension. Please include this bug report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: Tabbed Browser → Extension Compatibility
QA Contact: tabbed.browser → extension.compatibility
Resolution: --- → INVALID
Summary: Firefox 4b4 occasionally freezes on restart with multiple tabs (including app tabs ) open in two windows- buttons missing in the navigation toolbar also → Firefox 4b4 occasionally freezes on restart with multiple tabs (including app tabs ) open in two windows [caused by BabelFish]
(Reporter)

Comment 12

8 years ago
Sorry,I was pretty sure it was BabelFish,indeed once disabled all was OK for a while,trough several restart cycles,than the whole issue surfaced again,as I've said earlier,it is unfortunately quite random.I apologize if this has been misleading,there must be something else,the only thing I'm positive about is that before this b4 release this never happened.
So please continue testing with other extensions enabled while BabelFish is disabled. If you can't reproduce with all extensions disabled it's definitely an extension issue.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
Summary: Firefox 4b4 occasionally freezes on restart with multiple tabs (including app tabs ) open in two windows [caused by BabelFish] → Firefox 4b4 occasionally freezes on restart with multiple tabs (including app tabs ) open in two windows
(Reporter)

Comment 14

8 years ago
Sure,that's what I'm doing:the fact is,even enabling extensions one by one won't initially trigger this issue,I'll repeatedly restart the browser (using the"restart now" option in the add-ons manager) and everything will be OK,even with Babelfish (which possibly only by coincidence I enabled at the time this issue happened once again)-but,after  totally switching off the computer, the toolbar will likely reset (sometimes with tabs freezing) next time the browser is launched with the "remember windows & tabs" option enabled.I've also recently seen this https://bugzilla.mozilla.org/show_bug.cgi?id=592912,which sounds very similar.
(Reporter)

Comment 15

8 years ago
Created attachment 472273 [details]
list of current extensions at the time this bug happens
(Reporter)

Comment 16

8 years ago
OK,after much trying and having ruled out BabelFish (it works actually,my mistake) it all may be related to this extension Bookmark Current Tab Set 0.2.3 - I would however suggest,to avoid further confusion and before sending a compatibility report,that someone more experienced than me confirms this before wrapping up the bug,it is kinda tricky to reproduce because enabling this extension and restarting from the add-ons panel won't cause the problem,neither will exiting & relaunching the browser,a complete system shutdown and subsequent restart is apparently required,sometimes more than once.I'm attaching a list of my current extensions if anyone is willing to test this bug.
I will not have time for any testing in the near future. Could you please try to reproduce it in a fresh profile with only the Bookmark Current Tab Set extension installed? If the reported behavior can be reproduced it's clear that the extension has to be fixed. Thanks.
(Reporter)

Comment 18

8 years ago
 Excuse me for asking this:is it possible at all,that a disabled but not removed extension may still upset the browser? I'm still trying to isolate the issue,since none of the suspicious extensions named above actually misbehaves on a new profile,but I've also got some disabled (officially not compatible with 4.x) extensions  in the original troublesome profile,is technically possible that one of those may be at he heart of the problem?
(Reporter)

Comment 19

8 years ago
It has happened again,right after updating to this current b6 version:I wasn't able in the end -even after much trying- to isolate the cause,but after removing some disabled extensions & resetting toolbars and controls the issue was finally gone,and the browser has been stable until now.First restart after upgrading to beta 6,and tabs freeze with toolbar resetting again to default (as before,this doesn't affect all open windows)- to recap,it all started with b4,no issues before-is there anything that I should look for?
Have you ever experienced this freeze again with beta 7?
Whiteboard: [closeme 2010-09-15] → [closeme 2010-12-15]
(Reporter)

Comment 21

8 years ago
(In reply to comment #20)
> Have you ever experienced this freeze again with beta 7?

First restart right after upgrading to b7 was total havoc,saved windows and tab groups not reopening and freezing as well,so I'm currently using a second profile which works OK,if there's any useful info to be gathered from the first profile I'll try it again.
Closing as invalid since comment 7 implies addon is cause.

Please reopen/comment with further info, if you still see this issue with Firefox 4 Beta 8 or later in safe mode or with a clean profile (with no addons):
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_make-a-new-profile

Thanks!
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.