Closed Bug 590446 Opened 13 years ago Closed 13 years ago

Cannot change the case of a username remembered by the password manager

Categories

(Toolkit :: Password Manager, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 499649

People

(Reporter: sam, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

Discovered whilst installing Livelink EDMS. Both the username and password is case sensitive, and on a previous installation I'd used the username 'admin'. On the new install, the username was 'Admin'. However, because Firefox had remembered 'admin', if I typed 'Admin' it was automatically changed back to 'admin', preventing me from logging in until I realised it was a Firefox problem and not a Livelink problem, and cleared the remembered passwords (though only after performing multiple reinstallations).

Reproducible: Always

Steps to Reproduce:
1. Remember a username/password with lowercase username, and login.
2. Logout, and login again. Change username to be uppercase.
3. As soon as you click outside of the username field, username is changed back to being the case that was remembered
Actual Results:  
Firefox refuses to allow you to change the case of a remembered username. You can change the username to something completely different, but if only the case changes then it is forced back to the original case. Clearing the password from the password manager allows you to type in the correct username.

Expected Results:  
Usernames are considered case sensitive, and a change in case should be allowed without having to clear the passwords from the password manager.

I've tried this on a number of different sites, and the case always seems to be forced back to what was originally remembered.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
But bug 499649 was never fixed...

In this case, the solution would be to open the saved passwords and delete the username "admin".
You need to log in before you can comment on or make changes to this bug.