Float content below body element pushes down background-position: bottom

RESOLVED DUPLICATE of bug 333382

Status

()

Core
Layout: Floats
RESOLVED DUPLICATE of bug 333382
7 years ago
2 years ago

People

(Reporter: Sander, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

751 bytes, text/html
Details
(Reporter)

Description

7 years ago
Created attachment 469029 [details]
testcase

See the attached testcase. Chrome and Opera have the background image (the orange bar) bottom positioned to the regular block, while Gecko has it start at the bottom of the floating block, which sticks outside the body element. (Gecko's behaviour is more desired, imo, but Opera and webkit are correct according to the spec, as far as I understand it. This is dangerous with people mostly just testing in Firefox.)

Tested in gecko 2.0b3 20100805.
I guess the question here is something that's actually a little ambiguous in the spec:  whether the "root" block formatting context is established by the root element or by something above the root element.  If it's established by the root element, then the root should use the height rules in 10.6.7 and this is correct.  But I can't tell from 9.4.1 what establishes the root BFC.
Posted http://lists.w3.org/Archives/Public/www-style/2010Aug/0539.html
The CSS WG discussed this at today's meeting (and at the end of yesterday's) and concluded Gecko is wrong.
(Reporter)

Comment 4

6 years ago
FWIW, webkit seems to have since changed its behaviour, and is now doing the same as Gecko. (Since at least Chromium 14.)

Comment 5

6 years ago
(In reply to Sander from comment #4)
> FWIW, webkit seems to have since changed its behaviour, and is now doing the
> same as Gecko. (Since at least Chromium 14.)

Indeed, Safari 5.1.3 (534.53.10) and WebKit latest nightly (r107048) running on OS X 10.7.3 show the same behaviour as Gecko.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 333382
You need to log in before you can comment on or make changes to this bug.