PageDown doesn't clear title= tooltip

VERIFIED DUPLICATE of bug 50511

Status

()

Core
Event Handling
P3
trivial
VERIFIED DUPLICATE of bug 50511
18 years ago
18 years ago

People

(Reporter: Cesar Eduardo Barros, Assigned: joki (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17 i686; en-US; m18) Gecko/20001103
BuildID:    2000110308

Pointing to an element with a title= attribute shows a tooltip. Using PageDown
to move the page should be treated as the mouse moving out of it, i.e. the
tooltip should disappear. However, it doesn't disappear, and the scrolling feels
jerky (it shows a black background for half a second before drawing the newly
exposed parts of the page).

Reproducible: Always
Steps to Reproduce:
1. Open the page. Wait for it to load completely.
2. Go to View/Stylesheets and chose the "Default Style Sheet" item (the middle one)
3. Wait for it to load fully
4. Look for elements with a bluish (what's the real name of that color?) thingy
behind them (there are three in the page). One of them is in the "Other Test
Suites" section, a "PNG" link. The other two are harder to see, and in the
middle of the text in the beggining (grep the source for title=).
5. Hover over the element. A tooltip will appear.
6. Make sure you did whatever magic it is needed for PageDown to work (every
build has its own quirk; I always click somewhere in the background to be sure).
7. With the tooltip visible, hit PageDown in the keyboard.

Actual Results:  The tooltip stayed onscreen. The scrolling was not
instantaneous as normally, and the black (normally invisible) "background" is
seen for half a second while it redraws. Moving the mouse makes the tooltip go away.

Expected Results:  Treated PageDown as a mouse move, and thus made the tooltip
disappear.
Scrolled without extra noticeable delays.

Comment 1

18 years ago
Reported in 50511 "moving elements under mouse should act as if mouse has moved"


*** This bug has been marked as a duplicate of 50511 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

18 years ago
The extra delays aren't on that bug, are you sure it's _really_ a duplicate? (If
it is, you should note about the extra delay in 50511).

Comment 4

18 years ago
I'm not noticing a huge delay or colors messing up on Windows, but I'm not 
doing anything special to pixels that Mozilla doesn't specify colors for.  Are 
you using the thingie from jwz's site (http://www.jwz.org/hacks/marginal.html) 
or does linux always make those pixels black?
You need to log in before you can comment on or make changes to this bug.