If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

start and end time pull down menu format

RESOLVED DUPLICATE of bug 275253

Status

Calendar
Calendar Views
RESOLVED DUPLICATE of bug 275253
7 years ago
7 years ago

People

(Reporter: James, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729)
Build Identifier: lightning calendar add-on

It would be really nice when creating an event to have the start and end time pull down menu times be in 12 hour am, pm format instead of 24 hour format. Or possibly have an user selectable option for which format the pull down menu gives. I have a hard time thinking in terms of 24 hours, every time I have to do math when I want a particular am, pm time.

Reproducible: Always

Comment 1

7 years ago
What version of Lightning and what version of Thunderbird do you use?

Lightning should automatically use the date and time format specified by your operating system. I suggest that you check your system settings and retest.
(Reporter)

Comment 2

7 years ago
Thunderbird 3.1.2, and Lighting 1.0b2

The time format in XP uses lower case h for 12 hour format. The clock on the task bar displays as AM, and PM as well. 

The event times on the Lightning calendar are shown as AM, PM as well.

The only place in Lightning where AM, PM is not used on my computer is in the pull down menu selection for start and end times where it shows 0 to 23 with :00 to :55 minutes below that.

Thanks.
This should be covered with bug:
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 275253
You need to log in before you can comment on or make changes to this bug.