Last Comment Bug 590711 - panorama usage with MOZ_ACCELERATED=1: after click on "group tabs" button, firefox displays a totaly black window
: panorama usage with MOZ_ACCELERATED=1: after click on "group tabs" button, f...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86_64 Linux
: -- major with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-25 14:33 PDT by littlebzh
Modified: 2011-10-07 08:12 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description littlebzh 2010-08-25 14:33:53 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); fr; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

With Linux nvidia drivers 256.44, new default profile

When I want to use OpenGL with firefox 4b4, after export of MOZ_ACCELERATED=1, the group tab button (panorama feature) doesn't work correctly.
Firefox's window become black (I see a kde4's window with borders and decorations but everything is black inside (menu, bars, group tabs area) 
Mouse pointer seems to work normaly.
The pointer's shape changes when I move my mouse over the supposed areas with group of tab (hand, cross)  or in firefox's menu
It goes back to normal window after pressing of "ESC" or if I click anywhere in the window
The is no crash during my tests.

If I use MOZ_ACCELERATED=0, panorama works perfectly. 




Reproducible: Always

Steps to Reproduce:
1.in linux shell with nvidia drivers
export MOZ_ACCELERATED=1
./firefox -no-remote -ProfileManager
2.click on panorama button to group tabs or use group tabs menu.

Actual Results:  
Firefox's window becomes totaly black

Expected Results:  
a window with groups of tabs.


I get same results with i686 version (Mozilla/5.0 (X11; Linux i686 (x86_64); rv:2.0b4) Gecko/20100818 Firefox/4.0b4)
Comment 1 Donk 2010-08-27 07:25:13 PDT
I have the same problem on my ubuntu 10.04 (2.6.32-24-generic #41-Ubuntu SMP Thu Aug 19 01:38:40 UTC 2010 x86_64 GNU/Linux) but I use the Linux catalyst driver 10.7 and Gnome 2.30.

I have test with the i686 and x86_64 version of firefox4b4.
Comment 2 littlebzh 2010-09-01 09:55:57 PDT
After some update of kernel and nvidia's driver by mandriva (cooker), this bug persists

Linux 2.6.35.4-desktop-1mnb #1 SMP Sat Aug 28 04:04:18 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

driver nvidia : 256.53
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2010-09-01 10:04:40 PDT
Initially I suspected a nvidia bug, since the 256.xx are considered buggy.

But comment 1 says it happens on ATI too.
Comment 4 Michael Yoshitaka Erlewine [:mitcho] 2011-01-17 14:06:27 PST
Is this still occurring on more recent builds?
Comment 5 littlebzh 2011-01-17 14:43:28 PST
I forgot to test this bug with new beta.
I just tested with nvidia drivers 260.19.29 from mandriva cooker 64 bits
kernel : Linux hyperion 2.6.37-desktop-1mnb #1 SMP Wed Jan 5 14:35:48 CET 2011 x86_64 x86_64 x86_64 GNU/Linux

Panorama feature works perfectly now (no black screen) with the latest beta versions fo firefox and MOZ_ACCELERATED=1
Of course, it works with MOZ_ACCELERATED=0 too.


From "Troubleshooting Information" page 
    
GPU Accelerated Windows : 1/1

User agent : 

 - 4.0b9 32 bits : UA : Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
 - 4.0b9 64 bits : UA : Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

This bug is over for me. Great job.
Comment 6 Michael Yoshitaka Erlewine [:mitcho] 2011-01-17 14:47:48 PST
Can someone else also confirm and mark worksforme?
Comment 7 JP Rosevear [:jpr] 2011-10-07 08:12:33 PDT
Closing as resolved based on #5 and no further updates.

Note You need to log in before you can comment on or make changes to this bug.