Alt+f should invoke the Firefox menu button

RESOLVED DUPLICATE of bug 575279

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 575279
8 years ago
8 years ago

People

(Reporter: u88484, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
See bug 583386 comment 63

alt-f should open the new menu (and up-clicking the alt key without a modifier
should continue to temporarily display the traditional menu).  This is somewhat
morphing the behavior of ribbon apps like Wordpad, Paint and Office, with the
behavior of menu apps like Explorer and IE, but seems the best way to maintain
consistency with both.

After being invoked with alt-f, give the bookmarks command in the right pane
the focus, so the user can hit left to access the left pane, and right to
access the submenu of bookmarks (this will make sense to everyone else after I
post i6).

i6 is https://bugzilla.mozilla.org/attachment.cgi?id=465479
Wouldn't this break accessing the File menu using Alt+F? I think that'd be a pretty big accessibility regression.
Half of current windows apps use alt-f to access the ribbon, and the other half use alt(held down) to access the traditional menu bar.  We are in a strange position in that we want to try support both behaviors.  However, I believe many users who are using Firefox with keyboard control, are going to be upset if they see a new streamlined Firefox button, and they don't have a standard way of accessing it.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 575279
You need to log in before you can comment on or make changes to this bug.