Freeze when closing about:fennec tab opened from prefs

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 469373 [details] [diff] [review]
patch

Steps to reproduce (from Ioana Chiorean in bug 580197 comment 15):
1.Open Fennec
2.Slide the webpage to the left to reveal the control tab, press the gear icon
3.In preferences press About Fennec -> Go to Page
4.Slide the webpage to the right to reveal tabs and close last tab
(about:Fennec)

Results:  Fennec freezes with error "chrome://browser/content/browser.js, line 861: this._selectedTab.isLoading is not a function"

This is caused by #prefs-about-button passing a bad "owner" argument to BrowserUI.newTab.
Attachment #469373 - Flags: review?
(Assignee)

Updated

8 years ago
Attachment #469373 - Flags: review? → review?(21)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 590849
Comment on attachment 469373 [details] [diff] [review]
patch

And yeah we already bring up the tab to the front so we don't need that.
(if you could replace the ' by " when check-in :))
Attachment #469373 - Flags: review?(21) → review+
> (if you could replace the ' by " when check-in :))

nevermind
(Assignee)

Comment 4

8 years ago
http://hg.mozilla.org/mobile-browser/rev/0b158275cb7e
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
verified FIXED on builds:
Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b5pre) Gecko/20100826 Namoroka/4.0b5pre Fennec/2.0a1pre

and

Mozilla/5.0 (Android; Linux armv71; Nokia N900; en-US; rv:2.0b5pre) Gecko/20100826 Namoroka/4.0b5pre Fennec/2.0a1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.