Closed Bug 590867 Opened 9 years ago Closed 9 years ago

It is difficult to display context menu "Exit Full Screen Mode" by right-clicking, if browser is "Tabs on Top"

Categories

(Firefox :: Menus, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 4.0b12
Tracking Status
blocking2.0 --- -

People

(Reporter: alice0775, Assigned: at.light)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100825 Minefield/4.0b5pre ID:20100825062325
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100825 Minefield/4.0b5pre ID:20100825062325

It is difficult to display context menu "Exit Full Screen Mode" by right-clicking, if browser is "Tabs on Top".

if not "Tabs on Top", I move mouse pointer to the upper edge of the screen , then right-click, I can easily display context menu.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Make sure "Tabs on Top" (default in Wndows)
3. Open some page
5. Go to full screen mode (F11)
4. Try to popup contex menu "Exit Full Screen Mode"

Actual Results:
 comparatively difficult

Expected Results:
 Context menu of screen edge should include "Exit Full Screen Mode" menuitem.
 Generally the context menu of tab amd tab strip.
I think this should be fixed.
Severity: enhancement → normal
Keywords: regression
OS: Windows 7 → All
Target Milestone: --- → Firefox 4.0
Requesting feedback from UX.
blocking2.0: --- → ?
Keywords: uiwanted
Hardware: x86 → All
Target Milestone: Firefox 4.0 → ---
the same menu should ideally also be available in the title bar (area of the tab strip that does not contain tabs).
Blocking- since it only applies to full screen mode, and is still possible, just a little harder. If you think this blocks, please explain why we can't ship as-is.
blocking2.0: ? → -
Attached patch add context menu to tab bar (obsolete) — Splinter Review
Cheap and easy fix. Adds the two-item full screen context menu to the background of the tab bar.

alice suggested to append an "Exit Full Screen Mode" item to the tab context menus. This has low discoverability (the tab context menu is long enough), and users expect the Close Tab item to be last (on Windows at least).
Assignee: nobody → at.light
Status: NEW → ASSIGNED
Attachment #503449 - Flags: review?(dietrich)
Comment on attachment 503449 [details] [diff] [review]
add context menu to tab bar

Getting UI review from Alex first.
Attachment #503449 - Flags: ui-review?(faaborg)
Comment on attachment 503449 [details] [diff] [review]
add context menu to tab bar

Looks good
Attachment #503449 - Flags: ui-review?(faaborg) → ui-review+
Comment on attachment 503449 [details] [diff] [review]
add context menu to tab bar

r=me with the comment updated to include the tabs toolbar.
Attachment #503449 - Flags: review?(dietrich) → review+
Attachment #503449 - Attachment is obsolete: true
Attachment #503724 - Flags: ui-review+
Attachment #503724 - Flags: review+
Keywords: checkin-needed
This requires approval before it can land.
Keywords: checkin-needed
Attachment #503724 - Flags: approval2.0?
Comment on attachment 503724 [details] [diff] [review]
patch for checkin

a=beltzner, zero risk, please add the in-litmus flag when you check in.
Attachment #503724 - Flags: approval2.0? → approval2.0+
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/86dff995b060
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b12
Flags: in-litmus?
Verified fixed with Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110222 Firefox/4.0b12pre

Why can't this be tested with a browser chrome test?
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.