Modality for Javascript alert() and file upload dialog conflict

RESOLVED DUPLICATE of bug 476541

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 476541
7 years ago
7 years ago

People

(Reporter: Ben Burton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-US) AppleWebKit/534.6 (KHTML, like Gecko) Chrome/6.0.495.0 Safari/534.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

If you launch a file upload dialog it will have modal focus for the application. While in this context, if the current page encounters a Javascript alert() dialog, this will also have a modal focus. The problem is that you can neither close the file upload dialog nor the alert() dialog when this combination occurs.

Reproducible: Always

Steps to Reproduce:
1. Construct a website which has a file upload dialog and a Javascript alert() which is triggered shortly after the dialog appears.
2. Trigger the file upload dialog.
3. Wait for the Javascript alert() dialog to appear.
Actual Results:  
Use cannot click the "open" or "cancel" buttons on the file upload dialog. Additionally, the user cannot click the "ok" button on the Javascript alert() dialog either. The two dialogs are deadlocked, and the only way I've found to alleviate the problem is to force close Firefox.

Expected Results:  
The user should be able to close either the file upload dialog, or the Javascript alert() dialog so that they can continue to use the application.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476541
You need to log in before you can comment on or make changes to this bug.