Closed Bug 590963 Opened 12 years ago Closed 10 years ago

Google Maps - Earth View Causes Freeze

Categories

(Firefox :: General, defect)

x86_64
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jmakosky, Unassigned)

References

()

Details

(Keywords: hang)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4) Gecko/20100818 Firefox/4.0b4
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

With hardware acceleration enabled I visited maps.google.com. I turned on the Earth View and the browser becomes unresponsive during navigation for upwards of one minute.

Reproducible: Always

Steps to Reproduce:
1.Go to maps.google.com
2.Select Earth View
3.Zoom in and move around. Mozilla will become unresponsive. 
Actual Results:  
Unresponsive browser
I was able to reproduce this using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100826 Minefield/4.0b5pre, but I did not have to do anything but load the page and click "Earth View."

In my case, I received a dialog error that the "Display driver ATI Radeon Family had stopped responding." Reporter - did you see an error like that as well?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
No error from driver, however, I do have an ATI Video Chipset. ATI Mobility Radeon HD 4200.
Проблема существует, подтверждаю. Сильное зависание и падение сервиса.
The problem is, I do. A strong freeze and drop service.
Sounds like Bug 599661 - [D2D] Firefox periodically freezes on Thinkpad T400 with discrete/switchable graphics and needs force close when loading page
(In reply to comment #5)
> Sounds like Bug 599661 - [D2D] Firefox periodically freezes on Thinkpad T400
> with discrete/switchable graphics and needs force close when loading page

jmakosky, Bug 599661 is closed. so is this bug also gone in recent beta?
Keywords: hang
Still an issue on FF 11b2:
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Sometimes google earth plugin freezes Firefox.
Paul, Does it happen only if hardware acceleration is enabled ?
(In reply to Wayne Mery (:wsmwk) from comment #8)
> Paul, Does it happen only if hardware acceleration is enabled ?

I can reproduce the issue also with hardware acceleration OFF.
@Wayne, it there anything more QA can do to help you on this bug?
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #10)
> @Wayne, it there anything more QA can do to help you on this bug?

iirc my initial interest was premised on this being related to HWA. (I didn't test or see the bug myself)  But apparently it is not HWA, so my interest ends. sorry
Paul, 
still happens with nightly for you?
can you get a stacktrace or profile?
Hi Wayne,

This seems to be fixed now, I can no longer reproduce the freeze both on FF 14.0.1 and FF 17.0a1 (2012-08-06).
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.