Optimize tools repo checkout for unit test jobs

RESOLVED DUPLICATE of bug 712205

Status

Release Engineering
General
P3
normal
RESOLVED DUPLICATE of bug 712205
7 years ago
4 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [unittest])

(Reporter)

Description

7 years ago
On Windows machines can be more than 30 seconds process.
We currently clobber it and then check it out again when we could do "hg pull -u; hg up -C"
(Reporter)

Updated

7 years ago
Blocks: 586418
could we figure out which scripts we actually need and hit hgweb for those specific files?

wget http://%(hghost)s/%(toolsRepoPath)s/raw-file/%(rev)/%(fileNeeded)s
(Reporter)

Comment 2

7 years ago
I think unpack for dmg files. I believe we also use it for freeing space but there is plenty of space on the minis so I don't see the point.
(Reporter)

Updated

7 years ago
Priority: -- → P3

Comment 3

7 years ago
I think we're clobbering configs and tools because of staging -- we can pull a different repository.
We could also pull the required tools from http directly, and avoid using hg.

Comment 5

7 years ago
Still wanted?
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [unittest]
(Reporter)

Comment 6

7 years ago
Let me analyze it on bug 661585.

We might just wget the raw file we need from that repo instead of checking out the tools repo.
Blocks: 661585
(Reporter)

Updated

6 years ago
No longer blocks: 586418

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 712205
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.