Last Comment Bug 591101 - bholley testing bug for git-bz
: bholley testing bug for git-bz
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Bobby Holley (busy)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-26 16:31 PDT by Bobby Holley (busy)
Modified: 2015-10-09 15:25 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
test patch (1.35 KB, patch)
2010-08-26 16:50 PDT, Bobby Holley (busy)
no flags Details | Diff | Review
try 2 (1.35 KB, patch)
2010-08-26 16:53 PDT, Bobby Holley (busy)
no flags Details | Diff | Review
try 3 (1.35 KB, patch)
2010-08-26 16:59 PDT, Bobby Holley (busy)
no flags Details | Diff | Review
colon test (1.35 KB, patch)
2010-08-26 17:10 PDT, Bobby Holley (busy)
no flags Details | Diff | Review
final test (1.35 KB, patch)
2010-08-26 17:12 PDT, Bobby Holley (busy)
no flags Details | Diff | Review
patch v2 (2.96 KB, patch)
2010-08-31 14:44 PDT, Bobby Holley (busy)
no flags Details | Diff | Review
patch v2 (2.96 KB, patch)
2010-08-31 14:47 PDT, Bobby Holley (busy)
no flags Details | Diff | Review
patch v2 (2.98 KB, patch)
2010-08-31 15:03 PDT, Bobby Holley (busy)
no flags Details | Diff | Review
patch v2 (2.95 KB, patch)
2010-08-31 15:07 PDT, Bobby Holley (busy)
no flags Details | Diff | Review
patch v2 (2.98 KB, patch)
2010-08-31 15:07 PDT, Bobby Holley (busy)
no flags Details | Diff | Review
Bug 653930 - Tests. v1 (2.05 KB, patch)
2011-05-05 21:18 PDT, Bobby Holley (busy)
no flags Details | Diff | Review
Bug 653930 - v1 (3.43 KB, patch)
2011-05-05 21:18 PDT, Bobby Holley (busy)
bobbyholley: review-
Details | Diff | Review
Some nonsense from benoit. (1.24 KB, patch)
2011-11-29 21:30 PST, Bobby Holley (busy)
no flags Details | Diff | Review
More benoit nonsense. (1.18 KB, patch)
2011-11-29 22:02 PST, Bobby Holley (busy)
no flags Details | Diff | Review
Makoto magic! (1.21 KB, patch)
2011-11-29 22:05 PST, Bobby Holley (busy)
no flags Details | Diff | Review
First banner patch. (3.67 KB, patch)
2011-12-02 13:19 PST, Bobby Holley (busy)
no flags Details | Diff | Review
Banner patch 0. (1.19 KB, patch)
2011-12-02 13:20 PST, Bobby Holley (busy)
no flags Details | Diff | Review
Banner patch 1. (3.67 KB, patch)
2011-12-02 13:21 PST, Bobby Holley (busy)
no flags Details | Diff | Review
Replace the scripted closing unblocker termination function with an runnable. v1 (3.30 KB, patch)
2013-04-26 14:58 PDT, Bobby Holley (busy)
no flags Details | Diff | Review
Replace the scripted closing unblocker termination function with an runnable. v1 (3.62 KB, patch)
2013-04-26 15:09 PDT, Bobby Holley (busy)
no flags Details | Diff | Review
Element. (816 bytes, patch)
2015-09-21 17:15 PDT, Andrew McCreight [:mccr8]
continuation: superreview+
continuation: feedback+
Details | Diff | Review
Element. (816 bytes, patch)
2015-09-21 17:17 PDT, Andrew McCreight [:mccr8]
no flags Details | Diff | Review
Element. (816 bytes, patch)
2015-09-22 11:34 PDT, Andrew McCreight [:mccr8]
no flags Details | Diff | Review
Example file move with git. (265 bytes, patch)
2015-10-09 15:25 PDT, Andrew McCreight [:mccr8]
no flags Details | Diff | Review

Description Bobby Holley (busy) 2010-08-26 16:31:33 PDT
I've changed the QA contact - if anybody gets bugmail from this, please let me know and I'll figure out how to stop spamming you.
Comment 1 Bobby Holley (busy) 2010-08-26 16:50:23 PDT
Created attachment 469697 [details] [diff] [review]
test patch

Trying it out

Review: bobbyholley+bmo@gmail.com
Comment 2 Bobby Holley (busy) 2010-08-26 16:53:30 PDT
Created attachment 469698 [details] [diff] [review]
try 2

trying again.
Comment 3 Bobby Holley (busy) 2010-08-26 16:59:03 PDT
Created attachment 469700 [details] [diff] [review]
try 3

Third time's the charm
Comment 4 Bobby Holley (busy) 2010-08-26 17:10:33 PDT
Created attachment 469703 [details] [diff] [review]
colon test

This is to see if I can flag for :bholley
Comment 5 Bobby Holley (busy) 2010-08-26 17:12:15 PDT
Created attachment 469704 [details] [diff] [review]
final test

This test involves selecting multiple reviewers, selecting a super-reviewer, and mixing colon notation with regular bugmails.

If you get flagged for review by this, it means I can flag for review when pushing to bugzilla! Oh happy day.
Comment 6 Daniel Holbert [:dholbert] 2010-08-26 17:13:39 PDT
r+sr=dholbert!!
Comment 7 Phil Ringnalda (:philor) 2010-08-27 08:44:52 PDT
I'll get bugmail for it every night that it's open, since I have a query for bugs that don't have the right QA contact, but I eat bugspam for breakfast.
Comment 8 Bobby Holley (busy) 2010-08-27 08:47:03 PDT
(In reply to comment #7)
> I'll get bugmail for it every night that it's open, since I have a query for
> bugs that don't have the right QA contact, but I eat bugspam for breakfast.

I'll just close it for now then, and reopen it when I need it again.
Comment 10 Bobby Holley (busy) 2010-08-31 14:47:54 PDT
Created attachment 470916 [details] [diff] [review]
patch v2
Comment 14 Bobby Holley (busy) 2011-05-05 11:14:08 PDT
Looks like git-bz was broken by FF4, so I've got some more testing to do.

Buckle up philor. ;-)
Comment 15 Bobby Holley (busy) 2011-05-05 21:18:39 PDT
Created attachment 530530 [details] [diff] [review]
Bug 653930 - Tests. v1
Comment 16 Bobby Holley (busy) 2011-05-05 21:18:56 PDT
Created attachment 530531 [details] [diff] [review]
Bug 653930 - v1
Comment 17 Bobby Holley (busy) 2011-05-05 21:21:57 PDT
Comment on attachment 530531 [details] [diff] [review]
Bug 653930 - v1

Review of attachment 530531 [details] [diff] [review]:

overall comments.

more overall comments.

::: content/base/src/nsFrameLoader.cpp
@@ +865,5 @@
+void
+nsFrameLoader::MarginsChanged(PRUint32 aMarginWidth,
+                              PRUint32 aMarginHeight)
+{
+  // We assume that the margins are always zero for remote frames.

test comment

@@ +875,5 @@
+  // margins.
+  if (!mDocShell)
+    return;
+
+  // Set the margins

another test comment

::: content/base/src/nsFrameLoader.h
@@ +209,5 @@
 
   /**
+   * Called when the margin properties of the containing frame are changed.
+   */
+  void MarginsChanged(PRUint32 aMarginWidth, PRUint32 aMarginHeight);

last test comment
Comment 18 Bobby Holley (busy) 2011-05-05 21:24:01 PDT
All is well. Re-closing.
Comment 19 Bobby Holley (busy) 2011-11-29 21:16:26 PST
good evening :-)
Comment 20 Phil Ringnalda (:philor) 2011-11-29 21:23:57 PST
I actually switched that whine mail to monthly, and then stopped paying any attention to it, so if you want to just leave it open that's fine by me.
Comment 21 Bobby Holley (busy) 2011-11-29 21:30:52 PST
Created attachment 577859 [details] [diff] [review]
Some nonsense from benoit.
Comment 22 Bobby Holley (busy) 2011-11-29 21:32:22 PST
(In reply to Phil Ringnalda (:philor) from comment #20)
> I actually switched that whine mail to monthly, and then stopped paying any
> attention to it, so if you want to just leave it open that's fine by me.

but the metrics! ;-)
Comment 23 Bobby Holley (busy) 2011-11-29 22:02:49 PST
Created attachment 577863 [details] [diff] [review]
More benoit nonsense.
Comment 24 Bobby Holley (busy) 2011-11-29 22:05:57 PST
Created attachment 577864 [details] [diff] [review]
Makoto magic!
Comment 25 Bobby Holley (busy) 2011-12-02 13:19:33 PST
Created attachment 578692 [details] [diff] [review]
First banner patch.
Comment 26 Bobby Holley (busy) 2011-12-02 13:20:48 PST
Created attachment 578695 [details] [diff] [review]
Banner patch 0.
Comment 27 Bobby Holley (busy) 2011-12-02 13:21:06 PST
Created attachment 578696 [details] [diff] [review]
Banner patch 1.
Comment 28 Bobby Holley (busy) 2011-12-12 13:33:54 PST
Until next time!
Comment 29 Bobby Holley (busy) 2013-04-26 14:58:29 PDT
Created attachment 742575 [details] [diff] [review]
Replace the scripted closing unblocker termination function with an runnable. v1

The main idea behind this thing seems to be that we don't want script to quickly
close the window before the user has time to read the notification. Given the
fuzziness of the constraint here, I think we can (and maybe even should) unblock
a little bit later in the event loop, rather than immediately after the script
terminates.
Comment 30 Bobby Holley (busy) 2013-04-26 15:09:17 PDT
Created attachment 742580 [details] [diff] [review]
Replace the scripted closing unblocker termination function with an runnable. v1

The main idea behind this thing seems to be that we don't want script to quickly
close the window before the user has time to read the notification. Given the
fuzziness of the constraint here, I think we can (and maybe even should) unblock
a little bit later in the event loop, rather than immediately after the script
terminates.
Comment 31 Andrew McCreight [:mccr8] 2015-09-21 09:22:21 PDT
comment
Comment 32 Andrew McCreight [:mccr8] 2015-09-21 09:29:39 PDT
Comment on attachment 578695 [details] [diff] [review]
Banner patch 0.

comment
Comment 33 Andrew McCreight [:mccr8] 2015-09-21 09:29:39 PDT
Comment on attachment 742580 [details] [diff] [review]
Replace the scripted closing unblocker termination function with an runnable. v1

comment
Comment 34 Andrew McCreight [:mccr8] 2015-09-21 13:24:19 PDT
Comment on attachment 742575 [details] [diff] [review]
Replace the scripted closing unblocker termination function with an runnable. v1

test
Comment 35 Andrew McCreight [:mccr8] 2015-09-21 17:15:36 PDT
Created attachment 8663945 [details] [diff] [review]
Element.

comment
Comment 36 Andrew McCreight [:mccr8] 2015-09-21 17:17:23 PDT
Created attachment 8663946 [details] [diff] [review]
Element.
Comment 37 Andrew McCreight [:mccr8] 2015-09-22 11:34:45 PDT
Created attachment 8664388 [details] [diff] [review]
Element.
Comment 38 Andrew McCreight [:mccr8] 2015-10-09 15:25:35 PDT
Created attachment 8672144 [details] [diff] [review]
Example file move with git.

Note You need to log in before you can comment on or make changes to this bug.