Closed Bug 59126 Opened 19 years ago Closed 18 years ago

[RFE]multiple windows in one (tabbed browsing, MDI)

Categories

(SeaMonkey :: Tabbed Browser, enhancement, P2)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 100706
mozilla0.9.6

People

(Reporter: cesarb, Assigned: hyatt)

References

Details

(Keywords: helpwanted)

Attachments

(1 file)

Today I started middle-clicking random links in bugzilla, and then looked at my
screen and wondered, "wow this looks *real* crowded, and finding the right
window to point at to autoraise starts getting hard. I think they should be all
the same window."

Then I had the following idea:

Mozilla should have a mode in which, whenever there is a request to open a new
window (middle clicks, Javascript, target=, or any other devious means people
can came up with), it would instead open within a "virtual window". The user
would chose which "virtual window" to display by chosing in a
opening-time-ordered list in the sidebar. Then the current window would change
to that page.

This means *much* less cluter, much less work to find a window in the middle of
it (everybody who has opened 30+ browser windows in Windows knows that the
Explorer taskbar "icons" get impossible to read and look all the same), and even
less load on the windowing system. The user could use a special context menu
option ("Open in a Real Window"?) to expand one of the links to a real window,
and all new windows coming from that one would go to *that window*'s taskbar.

This is also a great solution to the "Javascript Popup Hell" problem -- just
make new Javascript windows go to the sidebar by default (configurable).
making rfe
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
Summary: Request for multiple windows in one → [RFE]multiple windows in one
I like this idea. I'm sure porn amateurs would be happy as hell with this. :)
Fabian.
over to XPApps.
Assignee: asa → don
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh
briank@clubi.ie: do you know if this is a dupe? ... Someone said there was a 
bitrotted xpi out there for this. I still think this is a dupe.
Some thoughts:

Many people find MDI (multiple document interface) which is what you are 
describing very difficult to use.

Some people think its the most evil user interface blunder Microsoft ever made.

Not even Microsoft, who invented it, use it any more. See IE5 or Office 2000 
which are moving towards eliminating MDI.

It never existed on Mac OS.

But, you know, who am I or anyone else to tell you what UI features you should or 
shouldn't want? By all means persue this.
So long as its not the default...
lordpixel, it's not what you are thinking it is. It's not 
progman.exe/winfile.exe style MDI. It's more of the "tabbed" MDI found in xchat 
(but with the tabs embedded in the sidebar and with a different style). 
Microsoft still uses it, in many huge configuration dialog boxes.

I want no "subwindows"; that would be evil. I just want to be able to use the 
same window for multiple things, switching between them at the click of a mouse.
Clicking Tasks/Navigator never opens more than two windows.
Open in new window or target=_blank could have the same effect.
You would have to rename the menu item "Open in other window".
added me to cc
No, Microsoft do not use MDI in dialog boxes, and nor have they ever done so. 
Tabbed dialog boxes do not contain documents, they contain a certain finite 
number of panels, where the controls outside the panels (e.g. `Cancel' and `Ok' 
buttons) operate on all the panels at once rather than just the visible panel. 
When the number of tabs gets larger than more than about six -- as they would if 
this was implemented -- you get the problems described in
<http://iarchitect.com/tabs.htm>.

As for various other points raised in this report:
* Preventing authors from opening new windows using scripts could be solved by
  bug 29346.
* Similarly, preventing authors from using TARGET to open links in a new window
  could be handled by bug 9805, so the user would be able to see that a link was
  going to open in a new window and would be able to use the context menu to
  override that.
* The problem of having dozens of small taskbar buttons on Windows can be solved
  by resizing the taskbar, and/or having it on the side of your screen instead of
  the top or bottom.
* Only a very small proportion of people would understand what `Open in a Real
  Window' meant, especially if there were any real windows in the room they were
  sitting in.
* You do not need to make a content-free comment in a bug when adding yourself to
  the CC list.
* Getting `Tasks' > `Navigator' to open more than one window is bug 20306.
*** Bug 60775 has been marked as a duplicate of this bug. ***
*** Bug 60956 has been marked as a duplicate of this bug. ***
I'm not sure what the terminology is, but I'd like to see Mozilla
implement multiple sub-windows in the same manner as Opera (you can get
an evaluation version from <http://www/opera.com>).  Each sub-window
has its own history, so I can navigate in one sub-window without
affecting the others.  I typically have a sub-window for each of
several web sites I want to follow.

The Eudora e-mail client has a similar sub-window mechanism.

This is on Windows; I'm not sure of the implications for other
operating systems.

I understand that some people don't like this feature (so make it
optional), but I find it to be extremely powerful and convenient.
The alternative of spawning multiple windows on my desktop is extremely
inconvenient, since I typically have several other applications
running simultaneously.  In fact, it's the main reason I'm willing
to pay for a copy of Opera, even though other browsers are free.
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy
nav triage team:

Definitely won't get to this for beta1, marking nsbeta1-
Keywords: nsbeta1-
hyatt mentioned recently in n.p.m.xpfe that he has been hacking some with a new 
<iwindow> element, a sub-window element.

Adding hyatt to cc for possible interest in this.
I will start using mozilla as my main browser (it's galeon now), as soon as it
implements tabbed browsing quite well. The sidebar would be a great opportunity
to list those virtual windows. Maybe this could be the first step to use mozilla
even as a window manager. Yes, it shouldn't be the default. But mozilla is a
heavy app, why not use it for your entire desktop? This could especially usefull
for embedded internet devices (less overhead).
New windows in mozilla are just too slow... this could be the all in one
solution. :) Of course optional please.

BTW: this bug is hard to find, could someone please add "tabbed browsing" and
"MDI" to the summary? I had to find this bug through a dup.
Adding keywords to summary as spark asked
Summary: [RFE]multiple windows in one → [RFE]multiple windows in one (tabbed browsing, MDI)
Marking nsbeta1- bugs as future to get off the radar
Target Milestone: --- → Future
I'd like to add something: it is also a performance issue. I once tried
skipstone (somewhere at www.muhri.net) - it has this feature as an option - tell
you what? New windows open with this "tabbed" method _times_ faster than with
new real windows. At my system - k6-2 350 Mhz 64 Mb RAM. BTW, even at this
configuration I like it ;) BTW2: skipstone has an amazine "recovering" feature -
I'm sure there is already a RFE about this - so far only Opera and skipstone
(maybe also Galeon) have this implemented....
I would love to see this implemented. I'm currently using Opera
(http://www.opera.com) as my main browser for this reason (well, and for the
memory usage...), but his DHTML support really sucks. 
*** Bug 82864 has been marked as a duplicate of this bug. ***
If it will implemented it _MUST_ be optional. I and many people out here dislike
the Opera MDI.

PS Offtopic: And look at Opera mem usage after 2-3 hours of browsing (I tried it
yesterday and it went from 7Mb to 57Mb without Java installed)...
I also don't like Opera's stuff, but love NetCaptor's tabs for instance. Sure, 
for some cases it would be better to be able to have two windows next to each 
other, but honestly I've never missed that for all the (long) time I use 
Netcaptor. And only lack of this feature in Mozilla keeps me with Netcaptor.
Look at Galeon, they did it great. 
You can open new windows either in a tab or in a new window. You can set the
default action. Shift+middelclick will open it the other way (new windows if tab
is default). This is VERY flexible, powerfull and doesn't hurt anyone.
Kinda good news: It seems that we talk about Multizilla - bug #80588 -
http://multizilla.mozdev.org/ - screenshots looks promising.
Yes, that look's promising!
I think this bug could be marked as a duplicate (or mark the other bug as a dup
of this one) and make damn sure, that this code goes into Mozilla 1.0 if it
works. Adding tabs to a simple Gtk or Win32 application shouldn't be much of a
problem. So please show us, that adding tabs for a XUL application isn't much of
a problem either. :) I was already worrying.
Try Ctrl-T with a recent mozilla build and watch the magic (and don't file a bug
on it looking bad in Classic...I've already done that).
Sweet!  Are there shortcut keys for switching between tabs?
->trudelle for triage. not sure if this should go to "nobody" or hyatt.
Assignee: vishy → trudelle
QA Contact: sairuh → jrgm
Should be closed as a dup of bug #100706 perhaps?
methinks 100706 is more backend implementation. adding dependency.
Depends on: 100706
Thanks for the suggestion.  As it happens, this is already in our engineering
plan. We're thinking of functionality similar to NetCaptor and MultiZilla, but
need to be more careful about integrating the UI.
->hyatt for now, P2/0.9.6
Assignee: trudelle → hyatt
Priority: P3 → P2
Target Milestone: Future → mozilla0.9.6
Component: XP Apps → Tabbed Browser
QA Contact: jrgm → blakeross

*** This bug has been marked as a duplicate of 100706 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.