Closed Bug 591490 Opened 9 years ago Closed 9 years ago

Move the search selector button to the right of the urlbar

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(fennec2.0b1+)

VERIFIED FIXED
Tracking Status
fennec 2.0b1+ ---

People

(Reporter: mbrubeck, Assigned: mfinkle)

References

Details

Attachments

(1 file)

Since the user must type a query *before* pressing the search button, the button should be to the right of the address field (next to the "go" button).

Madhava, do you agree?
I think one of madhava's designs has the button on the right side. We just have space issues to deal with. Should the favicon button hide, or get smaller?

I like the fact that the size of the urlbar stays the same.
But I agree that there are some issues with this model:
 * the button is always clickable even if you are into another view and this doesn't make sense since the textbox is not focused anymore and you could not have put custom text in it
 * the button is always clickable even if you have not type any text in it
 * the button and the functionnalities is hard to discover
 * the relationship between these search engine and the search action is not clear while it could be clearer if the button was on the right side
 * The icon is a magnifier while the hardware keyboard magnifier button is used to moved the focus into the urlbar!

What I like with this model:
 * The urlbar stays the same size
 * There is not useful space on the screen (the favicon was really unuseful here while this is one of the most easy place to touch on the screen)
 * We can use hardware keyboard to access the menu
 * The user already have an idea that this button open a "popup" and do not have to learn a new button
I think it should be at right, too (for LTR, anyway).  So long as this is a button that does something (i.e. initiates the search) rather than a mode selector, then it should follow the field.

In terms of space restrictions - I thought we were going to get rid of the site button on the awesomescreen.  We realized a bit late into the previous release that it doesn't actually serve any relevant function while on the awesomescreen, and, in some ways, doesn't make much sense, given that you're not really on the site anymore when you're in the awesomescreen.
Duplicate of this bug: 593454
The new design will move the search provider button to the right side of the
URLBar when in edit mode. Basic spec for when the URLBar is in edit mode is:
* favicon button (left endcap) disappears - maybe with a moz-transition.
* go/reload button becomes the search provider button.

The search provider button will work the same, choosing a provider starts a
search with whatever is in the textbox.
Assignee: mbrubeck → mark.finkle
tracking-fennec: --- → 2.0b1+
Attached patch patchSplinter Review
This patch:
* Hides the favicon button completely when in edit mode
* Adds a rounded border to the editbox when the favicon button is hidden
* Removes the "Go" button and all of it's images and XUL
* Moves the "Search" button to the right, replacing the "Go" button when in edit mode

The CSS should be RTL friendly
Attachment #471981 - Flags: review?(21)
Comment on attachment 471981 [details] [diff] [review]
patch

>diff --git a/themes/core/browser.css b/themes/core/browser.css

>+
>+#urlbar-container[mode="edit"] > #urlbar-edit {
>+  -moz-border-start: 3px solid #262629 !important;
>+  -moz-border-radius-topleft: 10px;
>+  -moz-border-radius-bottomleft: 10px;
>+}
>+
>+#urlbar-container[mode="edit"] > #urlbar-edit:-moz-locale-dir(rtl) {
>+  -moz-border-radius-topright: 10px;
>+  -moz-border-radius-bottomright: 10px;
> }

You need to reset the left border in RTL mode.


r+ with the border addressed.

I'm not sure to like the change in the urlbar look,this makes sense for the search button to move to the right,but I wonder if we should add back a button in the top-left corner? Anyway if we want to do that this will be an other bug...
Attachment #471981 - Flags: review?(21) → review+
(In reply to comment #7)
> Comment on attachment 471981 [details] [diff] [review]
> patch
> 
> >diff --git a/themes/core/browser.css b/themes/core/browser.css
> 
> >+
> >+#urlbar-container[mode="edit"] > #urlbar-edit {
> >+  -moz-border-start: 3px solid #262629 !important;
> >+  -moz-border-radius-topleft: 10px;
> >+  -moz-border-radius-bottomleft: 10px;
> >+}
> >+
> >+#urlbar-container[mode="edit"] > #urlbar-edit:-moz-locale-dir(rtl) {
> >+  -moz-border-radius-topright: 10px;
> >+  -moz-border-radius-bottomright: 10px;
> > }
> 
> You need to reset the left border in RTL mode.

I thought -moz-border-start would "just work" in RTL? What am I missing?
(In reply to comment #8)
> (In reply to comment #7)
> > Comment on attachment 471981 [details] [diff] [review] [details]
> > patch
> > 
> > >diff --git a/themes/core/browser.css b/themes/core/browser.css
> > 
> > >+
> > >+#urlbar-container[mode="edit"] > #urlbar-edit {
> > >+  -moz-border-start: 3px solid #262629 !important;
> > >+  -moz-border-radius-topleft: 10px;
> > >+  -moz-border-radius-bottomleft: 10px;
> > >+}
> > >+
> > >+#urlbar-container[mode="edit"] > #urlbar-edit:-moz-locale-dir(rtl) {
> > >+  -moz-border-radius-topright: 10px;
> > >+  -moz-border-radius-bottomright: 10px;
> > > }
> > 
> > You need to reset the left border in RTL mode.
> 
> I thought -moz-border-start would "just work" in RTL? What am I missing?

Sorry my comment was fuzzy, you need to reset the left border _radius_ for RTL mode.
Flags: in-testsuite?
Flags: in-litmus?
Ah, ok done.
pushed:
http://hg.mozilla.org/mobile-browser/rev/a1cb7922b8b7
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
yes, yes, a thousand times yes.
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b6pre)
Gecko/20100908 Namoroka/4.0b6pre Fennec/2.0b1pre

and

Mozilla/5.0 (Android; Linux armv71; Nokia N900; en-US; rv:2.0b6pre)
Gecko/20100908 Namoroka/4.0b6pre Fennec/2.0b1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.