sendchanges breaking on 1.9.1 builds

RESOLVED DUPLICATE of bug 560191

Status

RESOLVED DUPLICATE of bug 560191
8 years ago
5 years ago

People

(Reporter: aki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1282936788.1282944309.12606.gz
s: moz2-darwin9-slave22
OS X 10.5.2 mozilla-1.9.1 build on 2010/08/27 12:19:48

Executing: ['buildbot', 'sendchange', '--master', 'tools-staging-master.mv.mozilla.com:9010', '--username', 'sendchange', '--branch', 'mozilla-1.9.1-macosx-talos', '--revision', '595868e7f6772929d14f6900c359eec0ba6c68f9', 'http://stage.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-1.9.1-macosx/1282937222/firefox-3.5.13pre.en-US.mac.dmg']
program finished with exit code 0
elapsedTime=13.884604
=== Output ended ===
======== BuildStep ended ========
======== BuildStep started ========
sendchange
=== Output ===
[Failure instance: Traceback: <type 'exceptions.KeyError'>: 'testsUrl'
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:190:addCallback
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:181:addCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:323:_runCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/buildstep.py:753:_startStep_2
--- <exception caught here> ---
/tools/buildbotcustom/buildbotcustom/steps/misc.py:301:start
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:91:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:89:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:159:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:134:__getitem__
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:45:__getitem__
]
=== Output ended ===
======== BuildStep ended ========
======== BuildStep started ========
sendchange
=== Output ===
[Failure instance: Traceback: <type 'exceptions.KeyError'>: 'testsUrl'
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:190:addCallback
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:181:addCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:323:_runCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/buildstep.py:753:_startStep_2
--- <exception caught here> ---
/tools/buildbotcustom/buildbotcustom/steps/misc.py:301:start
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:91:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:89:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:159:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:134:__getitem__
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:45:__getitem__
]
=== Output ended ===
======== BuildStep ended ========
======== BuildStep started ========
sendchange
=== Output ===
[Failure instance: Traceback: <type 'exceptions.KeyError'>: 'testsUrl'
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:190:addCallback
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:181:addCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:323:_runCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/buildstep.py:753:_startStep_2
--- <exception caught here> ---
/tools/buildbotcustom/buildbotcustom/steps/misc.py:301:start
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:91:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:89:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:159:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:134:__getitem__
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:45:__getitem__
]
=== Output ended ===
======== BuildStep ended ========
======== BuildStep started ========
sendchange
=== Output ===
[Failure instance: Traceback: <type 'exceptions.KeyError'>: 'testsUrl'
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:190:addCallback
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:181:addCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:323:_runCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/buildstep.py:753:_startStep_2
--- <exception caught here> ---
/tools/buildbotcustom/buildbotcustom/steps/misc.py:301:start
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:91:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:89:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:159:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:134:__getitem__
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:45:__getitem__
]
=== Output ended ===
======== BuildStep ended ========
======== BuildStep started ========
sendchange
=== Output ===
[Failure instance: Traceback: <type 'exceptions.KeyError'>: 'testsUrl'
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:190:addCallback
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:181:addCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:323:_runCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/buildstep.py:753:_startStep_2
--- <exception caught here> ---
/tools/buildbotcustom/buildbotcustom/steps/misc.py:301:start
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:91:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:89:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:159:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:134:__getitem__
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:45:__getitem__
]

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1282936788.1282939565.24079.gz
s: moz2-linux-slave21
Linux mozilla-1.9.1 build on 2010/08/27 12:19:48

Executing: ['buildbot', 'sendchange', '--master', 'tools-staging-master.mv.mozilla.com:9010', '--username', 'sendchange', '--branch', 'mozilla-1.9.1-linux-talos', '--revision', '595868e7f6772929d14f6900c359eec0ba6c68f9', 'http://stage.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-1.9.1-linux/1282937073/firefox-3.5.13pre.en-US.linux-i686.tar.bz2']
program finished with exit code 0
elapsedTime=16.359300
=== Output ended ===
======== BuildStep ended ========
======== BuildStep started ========
sendchange
=== Output ===
[Failure instance: Traceback: <type 'exceptions.KeyError'>: 'testsUrl'
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:190:addCallback
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:181:addCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:323:_runCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/buildstep.py:753:_startStep_2
--- <exception caught here> ---
/tools/buildbotcustom/buildbotcustom/steps/misc.py:301:start
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:91:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:89:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:159:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:134:__getitem__
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:45:__getitem__
]
=== Output ended ===
======== BuildStep ended ========
======== BuildStep started ========
sendchange
=== Output ===
[Failure instance: Traceback: <type 'exceptions.KeyError'>: 'testsUrl'
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:190:addCallback
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:181:addCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:323:_runCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/buildstep.py:753:_startStep_2
--- <exception caught here> ---
/tools/buildbotcustom/buildbotcustom/steps/misc.py:301:start
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:91:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:89:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:159:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:134:__getitem__
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:45:__getitem__
]
=== Output ended ===
======== BuildStep ended ========
======== BuildStep started ========
sendchange
=== Output ===
[Failure instance: Traceback: <type 'exceptions.KeyError'>: 'testsUrl'
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:190:addCallback
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:181:addCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:323:_runCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/buildstep.py:753:_startStep_2
--- <exception caught here> ---
/tools/buildbotcustom/buildbotcustom/steps/misc.py:301:start
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:91:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:89:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:159:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:134:__getitem__
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:45:__getitem__
]
=== Output ended ===
======== BuildStep ended ========
======== BuildStep started ========
sendchange
=== Output ===
[Failure instance: Traceback: <type 'exceptions.KeyError'>: 'testsUrl'
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:190:addCallback
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:181:addCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:323:_runCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/buildstep.py:753:_startStep_2
--- <exception caught here> ---
/tools/buildbotcustom/buildbotcustom/steps/misc.py:301:start
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:91:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:89:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:159:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:134:__getitem__
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:45:__getitem__
]
=== Output ended ===
======== BuildStep ended ========
======== BuildStep started ========
sendchange
=== Output ===
[Failure instance: Traceback: <type 'exceptions.KeyError'>: 'testsUrl'
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:190:addCallback
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:181:addCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/Twisted-9.0.0-py2.6-linux-i686.egg/twisted/internet/defer.py:323:_runCallbacks
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/buildstep.py:753:_startStep_2
--- <exception caught here> ---
/tools/buildbotcustom/buildbotcustom/steps/misc.py:301:start
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:91:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:89:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:159:render
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:134:__getitem__
/tools/buildbot-0.8.0/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg/buildbot/process/properties.py:45:__getitem__
]
(Reporter)

Comment 1

8 years ago
John Ford says we shouldn't sendchange for unittests if the test archive is not generated.
(Reporter)

Comment 2

8 years ago
This is probably because 1.9.1 builds run unit tests on the builders?
See also bugs 581506, 560191.
(Reporter)

Comment 4

8 years ago
dholbert|sheriff & #developers were asking.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 560191
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.