The default bug view has changed. See this FAQ.

[1.9.1] test_CF_HTML_clipboard.html is perma-orange with "SimpleTest.waitForFocus is not a function"

VERIFIED FIXED in mozilla1.9.1

Status

()

Core
Editor
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: dholbert, Assigned: Ehsan)

Tracking

({verified1.9.1})

1.9.1 Branch
mozilla1.9.1
x86
Mac OS X
verified1.9.1
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(status1.9.1 .14-fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1282941921.1282944723.14877.gz
OS X 10.5.2 mozilla-1.9.1 test mochitests on 2010/08/27 13:45:21
s: moz2-darwin9-slave55
{
44652 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_CF_HTML_clipboard.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - SimpleTest.waitForFocus is not a function
}

Also affects the last 2 logs
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1282753500.1282756650.4149.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1282684691.1282686965.9322.gz

... and the logs before that are all orange, so I think they're also affected, but I haven't loaded them individually.

Based on the failure message, it looks like this test assumes functionality that we don't have on 1.9.1.  I'd guess that it's been permaorange ever since it was checked in (on July 30th, in http://hg.mozilla.org/releases/mozilla-1.9.1/rev/af24f6ef65b4 )

Ehsan, mind investigating?

(Note: I originally blamed bug 580151 -- the most recent push -- for this, until I noticed that it also affected the previous tinderbox cycle, a few days ago)
(Reporter)

Updated

7 years ago
Summary: test_CF_HTML_clipboard.html is perma-orange with "SimpleTest.waitForFocus is not a function" → [1.9.1] test_CF_HTML_clipboard.html is perma-orange with "SimpleTest.waitForFocus is not a function"
(Reporter)

Updated

7 years ago
Version: Trunk → 1.9.1 Branch
(Assignee)

Comment 1

7 years ago
Created attachment 470485 [details] [diff] [review]
Patch (v1)

I guess we should just use addLoadEvent...
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #470485 - Flags: review?(roc)
(Assignee)

Updated

7 years ago
Duplicate of this bug: 591750
Attachment #470485 - Flags: review?(roc) → review+
(Assignee)

Comment 3

7 years ago
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/99f51ed48a27
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
status1.9.1: --- → .13-fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1
(Assignee)

Comment 4

7 years ago
I also landed http://hg.mozilla.org/releases/mozilla-1.9.1/rev/22d43c7ca110 as a followup so that the test actually passes on 1.9.1!
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1283191547.1283195008.15439.gz
OS X 10.5.2 mozilla-1.9.1 test mochitests on 2010/08/30 11:05:47
44643 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_CF_HTML_clipboard.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - SimpleTest.waitForFocus is not a function

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1283267476.1283270580.31910.gz
OS X 10.5.2 mozilla-1.9.1 test mochitests on 2010/08/31 08:11:16
44638 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_CF_HTML_clipboard.html | Test timed out.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1283280865.1283283611.24624.gz
OS X 10.5.2 mozilla-1.9.1 test mochitests on 2010/08/31 11:54:25

V.Fixed
Status: RESOLVED → VERIFIED
Flags: in-testsuite+
Verified fixed for 1.9.1 based on passing automated test.
Keywords: verified1.9.1
You need to log in before you can comment on or make changes to this bug.