If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

have view source command load external program

VERIFIED DUPLICATE of bug 8589

Status

SeaMonkey
UI Design
P3
enhancement
VERIFIED DUPLICATE of bug 8589
17 years ago
13 years ago

People

(Reporter: Moses Lei, Assigned: don)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I was reading n.p.m.wishlist, and I saw a lot of references to IE's loading
source code in notepad. So here's an rfe.

1) Include the ability to hook the View Source command up to the program that is
specified for "Edit" in Windows File Types (Win only). In Windows IE this is
usually Notepad, Word, or Frontpage.

2) Include the ability to specify a program to view the source code in. (I would
use xemacs on unix)

Implementing this would give many users an advantage by being able to use their
favorite editor to do all the things that mozilla view source does and more (cut
and paste, syntax highlighting, regexp searching, etc.). It would also get rid
of many complaints about the syntax coloring issue (bug 52154).

As far as I know, the way IE does this is to pass the temporary file from the
cache to the external program via command line.

I think this should be included in mozilla1.0.
I found this also user friendly and I have filled out another [RFE] but this
RFE had benn marked invalid :-(

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 8589 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verfied dupe
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.