Last Comment Bug 591582 - Style Panel CSS properties are limited to hard coded values
: Style Panel CSS properties are limited to hard coded values
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Michael Ratcliffe [:miker] [:mratcliffe]
:
Mentors:
: 651443 (view as bug list)
Depends on: 582596
Blocks: 586984
  Show dependency treegraph
 
Reported: 2010-08-28 01:38 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2011-05-10 03:27 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Complete list of used and unused official and unofficial CSS properties sorted into groups (58.00 KB, application/vnd.ms-excel)
2011-04-28 03:54 PDT, Michael Ratcliffe [:miker] [:mratcliffe]
no flags Details
Unsupported properties to be moved to "other" group (44.51 KB, patch)
2011-05-05 07:45 PDT, Michael Ratcliffe [:miker] [:mratcliffe]
no flags Details | Diff | Review

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2010-08-28 01:38:25 PDT
CssHtmlTree contains a list of StyleGroupView items which group CSS properties. This list could easily get out of date.

(dolske) I think you really need a way to dynamically get a list of all known-to-Gecko CSS properties (which I believe are common to all elements?), group the ones this code knows about, and then plop everything else into this "Other" group. Alternatively, write a test that looks at these tables and fails when an new (unknown) property is added.

The problem here is that no one is going to remember to modify this code when new CSS properties are added in the future. So, either a test is needed to ensure people know to do that, or new properties should automatically show up somewhere generic (at which point users would presumably notice and file a bug to clean up the UI).
Comment 1 Michael Ratcliffe [:miker] [:mratcliffe] 2011-04-28 03:54:16 PDT
Created attachment 528819 [details]
Complete list of used and unused official and unofficial CSS properties sorted into groups

Complete list of used and unused official and unofficial CSS properties sorted
into groups.

The shorthand properties still need to be removed from the list.

A large amount of these properties can be found in
/layout/style/test/property_database.js but others were gathered from CSS 1, 2 & 3
standards websites.

Using this method we can categorize most properties. It would still be good to put any remaining CSS properties under the "Effects and Other" category.

Looking at the number of attributes in "Effects and Other" maybe we should split this into more categories?
Comment 2 Michael Ratcliffe [:miker] [:mratcliffe] 2011-04-28 03:55:39 PDT
*** Bug 651443 has been marked as a duplicate of this bug. ***
Comment 3 Michael Ratcliffe [:miker] [:mratcliffe] 2011-05-05 07:45:38 PDT
Created attachment 530312 [details] [diff] [review]
Unsupported properties to be moved to "other" group
Comment 4 Michael Ratcliffe [:miker] [:mratcliffe] 2011-05-06 07:59:23 PDT
Comment on attachment 530312 [details] [diff] [review]
Unsupported properties to be moved to "other" group

This patch has been added to the patch in bug 582596 to speed up the review process

Note You need to log in before you can comment on or make changes to this bug.