Last Comment Bug 591611 - Clean up FIREFOX_VERSION handling
: Clean up FIREFOX_VERSION handling
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: Ed Morley [:emorley]
:
Mentors:
Depends on: 591387
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-28 06:29 PDT by Kyle Huey [:khuey] (khuey@mozilla.com)
Modified: 2011-08-24 09:03 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (3.54 KB, patch)
2011-05-26 11:49 PDT, Ed Morley [:emorley]
khuey: review+
Details | Diff | Review

Description Kyle Huey [:khuey] (khuey@mozilla.com) 2010-08-28 06:29:13 PDT

    
Comment 1 Ed Morley [:emorley] 2011-05-07 11:19:26 PDT
Kyle, I'm presuming this is referring to bug 591387 comment 21? I'm slighly confused however due to bug 591387 comment 26 and also the fact that there is already:
AC_DEFINE_UNQUOTED(MOZ_UA_FIREFOX_VERSION, "$FIREFOX_VERSION"

...so why do we need this defined again as FIREFOX_VERSION?

I'm happy to do this cleanup, just unclear at present what of:
http://mxr.mozilla.org/mozilla-central/search?string=FIREFOX_VERSION
...needs changing to what.

Thanks!
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-05-07 12:53:29 PDT
MOZ_UA_FIREFOX_VERSION is something that's semantically different, even if it has the same value (it also has quotes).

I'd like to not touch that, and instead AC_DEFINE_UNQUOTED(FIREFOX_VERSION,$FIREFOX_VERSION).

Once that's done, any makefile that does something like

DEFINES += \
  -DFIREFOX_VERSION=$(FIREFOX_VERSION)

can have that bit removed.

As for bug 591387 comment 26, we can remove the AC_SUBST(MOZ_UA_FIREFOX_VERSION ...) and remove the autoconf.mk.in bit.

I would of course be happy to review.
Comment 3 Ed Morley [:emorley] 2011-05-26 11:49:33 PDT
Created attachment 535422 [details] [diff] [review]
Patch v1

- Removes |AC_SUBST(MOZ_UA_FIREFOX_VERSION)| in both configure.ins and the corresponding |MOZ_UA_FIREFOX_VERSION = @FIREFOX_VERSION@| in autoconf.mk.in , since MOZ_UA_FIREFOX_VERSION is not used in a Makefile anywhere (http://mxr.mozilla.org/mozilla-central/search?string=MOZ_UA_FIREFOX_VERSION)

- Adds |AC_DEFINE_UNQUOTED(FIREFOX_VERSION,$FIREFOX_VERSION)| to /configure.in, and then removes all |-DFIREFOX_VERSION=$(FIREFOX_VERSION)| (http://mxr.mozilla.org/mozilla-central/search?string=DFIREFOX_VERSION) since they are now redundant.
Comment 4 Ed Morley [:emorley] 2011-05-26 13:40:05 PDT
http://dev.philringnalda.com/tbpl/?tree=Try&rev=814ab5d45c97
Comment 5 Dão Gottwald [:dao] 2011-05-28 05:50:12 PDT
http://hg.mozilla.org/mozilla-central/rev/d1fb4ff8c16e
Comment 6 Simona B [:simonab] 2011-08-24 05:42:45 PDT
Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0

Is there any way I can verify this?

I looked in the files in the repo:
http://hg.mozilla.org/mozilla-central/file/e0acef471ab2

Is that enough to mark this as VERIFIED FIXED?

Thanks!

Note You need to log in before you can comment on or make changes to this bug.