Closed Bug 591741 Opened 9 years ago Closed 9 years ago

[SeaMonkey] mochitest-a11y: relations/test_tabbrowser.xul times out

Categories

(Core :: Disability Access APIs, defect, major)

defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla2.0b7

People

(Reporter: sgautherie, Assigned: sgautherie)

References

(Depends on 1 open bug, Blocks 1 open bug, )

Details

Attachments

(1 file)

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1283055773.1283058197.12882.gz&fulltext=1
Linux comm-central-trunk debug test mochitest-other on 2010/08/28 21:22:53
{
2259 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/relations/test_tabbrowser.xul | Test timed out.
}
http://brasstacks.mozilla.com/topfails/tests/SeaMonkey
doesn't list this test :-/
Depends on: 565307
It's not reported on Linux and Windows Tinderbox logs :-<
But, when I ran it on my local Windows recently, I got
{
2259 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/relations/test_tabbrowser.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - tabBrowser.addProgressListener is not a function at chrome://mochikit/content/a11y/accessible/relations/test_tabbrowser.xul:58
2260 INFO SimpleTest finished chrome://mochikit/content/a11y/accessible/relations/test_tabbrowser.xul in 180ms
}
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Depends on: 558589
OS: Linux → All
Hardware: x86 → All
Ftr, the Error Console logs:
{
Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.sessionHistory]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/browser.xml ::  :: line 647"  data: no]
Source File: chrome://global/content/bindings/browser.xml
Line: 653

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.sessionHistory]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/browser.xml ::  :: line 647"  data: no]
Source File: chrome://global/content/bindings/browser.xml
Line: 653

Error: aBrowser is undefined
Source File: file:///E:/Dvlp/Mozilla/SM21/seamonkey/components/nsSessionStore.js
Line: 624

Error: element.onLocationChange is not a function
Source File: chrome://navigator/content/tabbrowser.xml
Line: 850
}
but the test passes.
So, I don't know whether the cause of these is in the test or in SeaMonkey :-/
Attachment #473507 - Flags: review?(surkov.alexander)
Comment on attachment 473507 [details] [diff] [review]
(Av1) Bind chrome://navigator/content/navigator.css for SeaMonkey
[Checkin: Comment 5]

r=me, thank you for working on this
Attachment #473507 - Flags: review?(surkov.alexander) → review+
Comment on attachment 473507 [details] [diff] [review]
(Av1) Bind chrome://navigator/content/navigator.css for SeaMonkey
[Checkin: Comment 5]

http://hg.mozilla.org/mozilla-central/rev/84fdf8e52709
Attachment #473507 - Attachment description: (Av1) Bind chrome://navigator/content/navigator.css for SeaMonkey → (Av1) Bind chrome://navigator/content/navigator.css for SeaMonkey [Checkin: Comment 5]
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b6
V.Fixed, per
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1284066166.1284068225.4738.gz
Linux comm-central-trunk debug test mochitest-other on 2010/09/09 14:02:46
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.