Javascript Error: InstallTrigger is not defined when reloading tab in background, then try to install extension

VERIFIED FIXED in mozilla2.0b7

Status

()

VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: martijn.martijn, Assigned: azakai)

Tracking

Trunk
mozilla2.0b7
x86
Windows 7
Points:
---
Bug Flags:
in-testsuite ?
in-litmus -

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(URL)

(Reporter)

Description

8 years ago
I'm getting this error and am unable to install the extension in the url:
Error: InstallTrigger is not defined
Source File: https://addons.mozilla.org/media//js/common-min.js?build=060c88b
Line: 16

Steps to reproduce:
- Visit mentioned url
- Open a new tab.
- Open the context menu over the tab of mentioned url page, click on "Reload Tab", wait for that page to be reloaded.
- Switch to that page, then try to install that extension

Expected result:
- Installation dialog should come up.

Actual result:
- Javascript error as mentioned earlier.

Btw, I was noticing while doing a session restore.
This sounds like a Firefox bug since InstallTrigger is a Gecko API.  What browser version do you have?
Alon, does bug 589598 fix this too?
(Assignee)

Comment 3

8 years ago
(In reply to comment #2)
> Alon, does bug 589598 fix this too?

Yes, I can confirm that this bug is fixed by the patch to that bug. (Apparently the events during reload are similar to those in iframes?)
blocking2.0: --- → betaN+
Component: Public Pages → Add-ons Manager
Depends on: 589598
Product: addons.mozilla.org → Toolkit
QA Contact: web-ui → add-ons.manager
Version: unspecified → Trunk
Fixed by bug 589598
Assignee: nobody → azakai
Flags: in-testsuite?
Flags: in-litmus-
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b6
This is not fixed. I'm stable to reproduce it with the steps in comment 0 and Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100903 Firefox/4.0b6pre
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 6

8 years ago
Yes, they backed out the patch for bug 589598.
Darn, forgot that. Thanks.
(Assignee)

Comment 8

8 years ago
A proper patch for bug 589598 has landed (see link there).
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Verified fixed with Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101204 Firefox/4.0b8pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.