Closed Bug 591852 Opened 11 years ago Closed 11 years ago

Reduce add-ons manager screen waste

Categories

(Toolkit :: Add-ons Manager, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla2.0b8
Tracking Status
blocking2.0 --- -

People

(Reporter: fehe, Unassigned)

References

Details

(Keywords: access)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100829 Firefox/4.0b5pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100829 Firefox/4.0b5pre ID:20100829040614

The new AOM wastes a lot of screen real estate -- especially the huge gap between the tabs options on the left and the scrollable list (see attached screenshot).

If there is no legitimate reason for the waste, would it be possible to get as much of this reduced as possible, as it contributes to unnecessary scrolling and is not very friendly on smaller displays (e.g. netbooks, small-screen laptops, tablets, etc.)?

Thanks

Reproducible: Always
Version: unspecified → Trunk
Dave, I haven't tested localized builds yet with the new style. Are we flexible enough to readjust the width of the category panel depending on the localized category name?
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
(In reply to comment #2)
> Dave, I haven't tested localized builds yet with the new style. Are we flexible
> enough to readjust the width of the category panel depending on the localized
> category name?

I don't believe so, but we could make that possible somehow I guess.

This doesn't block but I probably would take a UI reviewed patch.
blocking2.0: ? → -
(In reply to comment #3)
> (In reply to comment #2)
> > Dave, I haven't tested localized builds yet with the new style. Are we flexible
> > enough to readjust the width of the category panel depending on the localized
> > category name?
> 
> I don't believe so, but we could make that possible somehow I guess.

Axel, you know someone from the localizer group who would be interested in?
I suspect that the width is coming from the longest item, which in my case is the non-active "Zuletzt durchgeführte Updates" listitem.

I bet the same thing is true for the en-US screenshot.

If you set that item to hidden="true", it takes much less real screen estate.
(In reply to comment #5)
> I suspect that the width is coming from the longest item, which in my case is
> the non-active "Zuletzt durchgeführte Updates" listitem.
> 
> I bet the same thing is true for the en-US screenshot.
> 
> If you set that item to hidden="true", it takes much less real screen estate.

Yep, that was my thinking too. Unfortunately, if we do that, once it appears all the main content will suddenly jump as its resized.
I guess in an optimal world, we'd animate that?

But for now, I'd think that that jumping is more of a bug than a feature, how often do we have the add-ons manager in sight when updates show. And if, it's probably as a response to an explicit check for updates, so it won't come as a surprise?
Here's an example of someone who has to set his screen resolution to 800 x 600, because of bad eyesight, and yet he has to switch to at least 1024 x 768 to use the new AOM: http://forums.mozillazine.org/viewtopic.php?p=9870059#p9870059
Keywords: access
(In reply to comment #7)
> But for now, I'd think that that jumping is more of a bug than a feature, how
> often do we have the add-ons manager in sight when updates show. And if, it's
> probably as a response to an explicit check for updates, so it won't come as a
> surprise?

It'll more likely be due to automatic checks, but I guess that will usually occur when the addons manager isn't openned (so will show when it is opened) or isn't being actively used.
Recent builds have made this much better for small screens; therefore, I'm going to consider this fixed as of: http://hg.mozilla.org/mozilla-central/rev/7f5cd850578e

Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre ID:20101124042634
Status: NEW → RESOLVED
Closed: 11 years ago
Depends on: 601022
Resolution: --- → FIXED
Right, I can verify it. Additionally we now even hide the category names if the window gets too narrow.
Status: RESOLVED → VERIFIED
Flags: in-testsuite-
Flags: in-litmus-
Target Milestone: --- → mozilla2.0b8
You need to log in before you can comment on or make changes to this bug.