Closed Bug 591973 Opened 9 years ago Closed 9 years ago

Persisted window location might be restored to an off-screen location

Categories

(Core :: XUL, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking2.0 --- final+

People

(Reporter: gaubugzilla, Assigned: jimm)

References

Details

(Keywords: regression)

Attachments

(1 file)

This issue can be reproduced with Adblock Plus but should affect other extensions as well. Steps to reproduce:

1. Install Adblock Plus 1.2.2
2. In Firefox 4: Open Add-on Manager. If you want to compare properly in Firefox 3.6: Open chrome://mozapps/content/extensions/extensions.xul in a tab.
3. Resize your browser window to occupy only half of the screen and move it to the left edge of the screen.
4. Right-click Adblock Plus entry in the add-on manager and choose "Options". Move the options window to the right edge of the screen and close it.
5. Now move the browser window to the right edge of the screen and open Adblock Plus options again.

Expected results:

The options window still opens within screen boundaries despite all position persistence. That's the result I see in Firefox 3.6.8

Actual results:

What I see with the current nightly (Gecko/20100829 Firefox/4.0b5pre on Windows 7 x64): The window is almost invisible, the left edge of it is barely visible at the right edge of the screen. In fact, this was reported as a hang caused by Adblock Plus - add-on manager opens options as a modal dialog, the browser window is unusable until that dialog is closed.
There's code in widget designed to prevent windows from being opened off screen. How much of the options dialog is visible? Can you post a screen shot?
blocking2.0: --- → ?
Please renominate if more data becomes available.
blocking2.0: ? → ---
Attached image Screenshot
See screenshot. I clicked Options for the Adblock Plus extension, the window is barely visible on the right edge of the screen - only 7 pixel, the width of the window border.
blocking2.0: --- → ?
Assignee: nobody → jmathies
blocking2.0: ? → final+
Blocks: 574690
No longer blocks: abp
yet another side effect from the patch in bug 574690, which I'm planning to
back out.
The patch that caused this (bug 574690) has been backed out. Should be fixed in tomorrow's nightly.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Confirmed, works for me in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101017 Firefox/4.0b8pre.
You need to log in before you can comment on or make changes to this bug.