Images taller or wider than 32767px fail to display on trunk / OS X

RESOLVED DUPLICATE of bug 591822

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 591822
7 years ago
3 years ago

People

(Reporter: philippe (part-time), Unassigned)

Tracking

({regression})

Trunk
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
(spin off from bug 591822)

This works fine in Gecko 1.9.2 based browsers, fails with Gecko 2.0a browsers

Testcase: data:text/html,<img%20src="https://bugzilla.mozilla.org/attachment.cgi?id=470331"%20height="100"%20width="100">%20This%20should%20be%20a%20green%20rectangle.

image used: attachment 470331 [details]

regression range:

fails
Gecko/20100427 Minefield/3.7a5pre
http://hg.mozilla.org/mozilla-central/rev/29a6a85fab8e

works
Gecko/20100426 Minefield/3.7a5pre
http://hg.mozilla.org/mozilla-central/rev/2968d19b0165

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2968d19b0165&tochange=29a6a85fab8e

Possibly:
f236632a9747    Jeff Muizelaar — Bug 542605. Update cairo to
12d521df8acc483b2daa844d4f05dc2fe2765ba6. r=vlad,jwatt,bas Reland after fixing
quartz related clipping bug and a bunch of other ones

Comment 1

7 years ago
Same regression range on Windows. Duping.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 591822
You need to log in before you can comment on or make changes to this bug.