Closed Bug 592361 Opened 11 years ago Closed 11 years ago

Implement Workspace in browser

Categories

(DevTools :: General, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 642176

People

(Reporter: ddahl, Unassigned)

Details

(Whiteboard: [post-fx-4])

A JSTerm object can create a stand-alone "Terminal" for a contentWindow. We need to integrate this into the web console tools / UI.

The use case is where you want a stand-alone terminal that is not polluted by logging messages, much like Jesse's JSShell

Most of this work is the UI integration and UX.
Whiteboard: [post-fx-4]
Dupe of implement workspace bug - rob, what bug is that?
I think we need a proper "create workspace in browser" bug. Most recent I could find was, bug 636723 and that's going away.
Summary: WebConsole: Implement JS Workspaces → Implement Workspace in browser
Just changed this bug's title for the workspace work:)
duping forward.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 642176
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.