Closed Bug 592424 Opened 12 years ago Closed 10 years ago

NS_STATE_ACCELTEXT_IS_DERIVED is never removed once set

Categories

(Core :: XUL, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: Gavin, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

The code intends to remove it, but doesn't, because of a mistake in one of the patches for bug 190735.
This makes it impossible to change a menuitem's acceltext after it's been set at frame construction time, since the attribute changed handler calls BuildAcceleratorText, which doesn't hit the short circuit check for non-derived non-blank values, and therefore clobbers the set value.
Attached patch patch (obsolete) — Splinter Review
test_bug511075 is causing some kind of interference with the test when run in batch-mode (as opposed to individually) - need to investigate that further.
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attached patch patchSplinter Review
Attachment #471143 - Attachment is obsolete: true
I'm also changing the behavior slightly, to allow removing the accelText entirely (i.e. setting to "") - useful for bug 589139. The old code overrides if the attribute is empty/nonexistent - the new code allows setting to "", and requires removing the attribute to have it be reset by BuildAcceleratorText().
blocking2.0: --- → ?
Depends on: 583957
Keywords: regression
Whiteboard: [patchlove]
blocking2.0: ? → ---
status1.9.1: ? → ---
status1.9.2: ? → ---
No longer depends on: 583957
Whiteboard: [patchlove]
Depends on: 630830
Fixed by bug 630830 (http://hg.mozilla.org/mozilla-central/rev/561a1d421cec), but I probably want to spin off a bug for the behavior change because I think that'd be useful.
I'm not going to ever follow up on this...
Assignee: gavin.sharp → nobody
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Component: XP Toolkit/Widgets: Menus → XUL
You need to log in before you can comment on or make changes to this bug.