Linux trunk builds failing [xpcquickstubs.h:134: internal compiler error: Segmentation fault]

RESOLVED FIXED in 1.0b4

Status

defect
--
blocker
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Fallen, Assigned: Fallen)

Tracking

Lightning 1.0b2
1.0b4
x86
Linux
Bug Flags:
blocking-calendar1.0 +

Details

While compiling xpcwrappednative.cpp:

/builds/buildbot/comm-central-lightning-linux/build/mozilla/js/src/xpconnect/src/xpcquickstubs.h: In constructor ‘qsObjectHelper::qsObjectHelper(T*, nsWrapperCache*)’:
/builds/buildbot/comm-central-lightning-linux/build/mozilla/js/src/xpconnect/src/xpcquickstubs.h:134: internal compiler error: Segmentation fault

Any idea whats going wrong here? I've heard in #developers that internal compiler errors sometimes are caused by failing disks or memory? Is our compiler (gcc-4.1.1) too old?
(Assignee)

Updated

9 years ago
Severity: normal → blocker
Flags: blocking-calendar1.0+
(Assignee)

Comment 1

9 years ago
Fixed by upgrading linux builder to gcc-4.3.3. Hourly builds are green, nighly builds should follow.

http://hg.mozilla.org/build/buildbot-configs/rev/d0d66125dff3
http://hg.mozilla.org/build/buildbot-configs/rev/9d9af6e1c43c
Assignee: nobody → philipp
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0b3
Target Milestone: 1.0b3 → Trunk
You need to log in before you can comment on or make changes to this bug.