Don't report add-ons as incompatible if they are already incompatible with the current version

RESOLVED FIXED

Status

()

Toolkit
Application Update
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

Trunk
Points:
---
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Comment hidden (empty)
Created attachment 471205 [details] [diff] [review]
patch rev1
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #471205 - Flags: review?(dtownsend)
Attachment #471205 - Attachment is patch: true
Attachment #471205 - Attachment mime type: application/octet-stream → text/plain
Comment on attachment 471205 [details] [diff] [review]
patch rev1

Should be able to simplify those to just addon.isCompatible
Attachment #471205 - Flags: review?(dtownsend) → review+
Attachment #471205 - Flags: approval2.0+
Created attachment 471232 [details] [diff] [review]
patch - comment addressed - ready for checkin
Attachment #471232 - Flags: review+
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/1d82f70c5239

minusing in-testsuite and in-litmus since this is a fix for an edgecase where the user has added the hidden checkCompatibility.x.x preference
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite-
Flags: in-litmus-
Resolution: --- → FIXED

Updated

7 years ago
Duplicate of this bug: 527141
You need to log in before you can comment on or make changes to this bug.