IndexedDB: IDBRequest rework, make everything an event target

RESOLVED FIXED

Status

()

Core
DOM: IndexedDB
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: Ben Turner (not reading bugmail, use the needinfo flag!), Assigned: Ben Turner (not reading bugmail, use the needinfo flag!))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Comment hidden (empty)
Created attachment 471217 [details] [diff] [review]
Patch, v1

This makes everything an event listener, removes abort from IDBRequest, and simplifies event target creation.
Attachment #471217 - Flags: review?(jonas)
Summary: IndexedDB: IDBRequest rework, make everything an event listener → IndexedDB: IDBRequest rework, make everything an event target
http://hg.mozilla.org/mozilla-central/rev/bb3b8e8f2b79
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Now that more things are cycle collected some threadsafety assertion (that I've still never been able to reproduce) is causing aborts. Pushed this to bulletproof everything. Hopefully it will stick.

http://hg.mozilla.org/mozilla-central/rev/c9f69a3d43af
Created attachment 473974 [details] [diff] [review]
Backout patch, just in case

Just in case (everything looks fine so far) here is a patch to back out this patch without needing to backout the others it landed with (UI for beta 6). Hoping this can just sit here.
Comment on attachment 473974 [details] [diff] [review]
Backout patch, just in case

Looks like this won't be necessary after all!
Attachment #473974 - Attachment is obsolete: true
Duplicate of this bug: 585471
Component: DOM → DOM: IndexedDB
You need to log in before you can comment on or make changes to this bug.