Closed Bug 593160 Opened 12 years ago Closed 12 years ago

[DWrite] failure in layout/reftests/text/wordwrap-03.html on Windows 7 with bug 240933

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla2.0b7

People

(Reporter: ehsan.akhgari, Assigned: dbaron)

References

Details

Attachments

(1 file)

Attached file Reftest failure log
Jeff said that this could be a d2d problem...
The failure was from:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1283463040.1283464387.29725.gz
Rev3 WINNT 6.1 mozilla-central opt test reftest on 2010/09/02 14:30:40
I'm fairly certain that this happens with my patches in bug 240933.  I've backed it out, and I'm bisecting locally to figure out what caused this.
Assignee: nobody → ehsan
Blocks: 240933
No longer blocks: 438871
Status: NEW → ASSIGNED
Component: Graphics → Editor
QA Contact: thebes → editor
Summary: [D2D] Intermittent failure in layout/reftests/text/wordwrap-03.html → failure in layout/reftests/text/wordwrap-03.html on Windows 7 with bug 240933
Whiteboard: [orange]
So, it seems that this failure happens on Win7 with d2d enabled with a build from <http://hg.mozilla.org/mozilla-central/rev/b73bb8fcce79>, but doesn't happen when d2d is disabled.  So this sounds like a D2D problem which is triggered by that patch.  Jeff/Bas: could you guys help me debug this?
Assignee: ehsan → nobody
Component: Editor → Graphics
QA Contact: editor → thebes
Summary: failure in layout/reftests/text/wordwrap-03.html on Windows 7 with bug 240933 → [D2D] failure in layout/reftests/text/wordwrap-03.html on Windows 7 with bug 240933
The failure happens with GDI + DirectWrite as well.
Then it's not a D2D failure :)
Summary: [D2D] failure in layout/reftests/text/wordwrap-03.html on Windows 7 with bug 240933 → [DWrite] failure in layout/reftests/text/wordwrap-03.html on Windows 7 with bug 240933
I tried to replace the textarea element in this test and its reference file with a pre element, and the same failure happened again.  I discussed it with Jeff, and he agreed that this is a DirectWrite bug which has just been exposed by my patch, but is not a regression from it.  Therefore I'm going to add a patch to bug 240933 to disable that test if d2d is turned on, until the underlying problem is solved in this bug.
No longer blocks: 240933
I got an unexpected pass on this from something in my patch queue.  I'm not sure what, though, and I hadn't pushed my queue to Win7 unit tests for quite a while (since they're so slow, and we're trying to conserve try resources, so I generally use the fast ones).

Odds are it's somehow bug 542595, though.
I confirmed that it is bug 542595, and that it changes the result from test and reference having enabled scrollbars of slightly different lengths to the scrollbars being disabled in both.  Does that seem like a sensible result?

(It seems like it to me, since I'm presuming the overflow that was causing scrollbars was overflow of glyphs extending outside their bounds.)
And note that this is in some sense less a DWrite bug than a DWrite feature; if my memory is correct, we didn't report correct text overflow on Windows (ClearType) before, even though it caused bugs, because we didn't want the extra scrollbars in cases like these.  Bug 542595 fixes the issue of extra scrollbars and allows us to do that.  (We should probably fix the non-DWrite code as well once bug 542595 lands.)
Assignee: nobody → dbaron
Fixed by bug 542595.  In particular, see:
http://hg.mozilla.org/mozilla-central/rev/b9d3ba34dc5e
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Depends on: 542595
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
Target Milestone: mozilla2.0b8 → mozilla2.0b7
You need to log in before you can comment on or make changes to this bug.