Firefox 4.0b4 uses 100% CPU with large numbers of tabs after resume from sleep

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: GPHemsley, Unassigned)

Tracking

({hang, qawanted, stackwanted})

Trunk
x86_64
Mac OS X
hang, qawanted, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 471887 [details]
Sample from Activity Monitor

I am using 32-bit Firefox 4.0b4 on 64-bit Mac OS X 10.6.4 (quad core). (I briefly upgraded to 4.0b5 candidate build 1, and it also experienced this problem.)

I have my computer set up to go to sleep after the computer is idle for a certain amount of time. When I return, very often I find Firefox in an unusable state. The entire application grinds to a halt, and Activity Monitor reports that Firefox is using about 100% of the CPU (and sometimes more!).

Attempting to actually use Firefox after that proves impossible, as Firefox creeps along at a pace slower than dialup circa 1995. The only solution I've found (and it's a temporary one, since the computer will inevitably go back to sleep at some point in the future) is to kill Firefox and reopen it.

I haven't been able to determine if this is related to bug 590674.

Comment 1

7 years ago
Does it happen after every waking up ? or sometimes ?
What about the sleep waking up if firefox is in safe mode :
http://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Does it happen after every waking up ? or sometimes ?
> What about the sleep waking up if firefox is in safe mode :
> http://support.mozilla.com/en-US/kb/Safe+Mode

Well, I'm running Safe Mode right now, and the CPU is running high. (It spikes around 100%, but sometimes drops down to ~80%.)

Unfortunately, the problem may not have anything to do with the computer sleeping at all, as I don't think the computer has gone to sleep since I started Firefox in Safe Mode.

I wonder if this perhaps has something to do with Flash? App Tabs and Tab Candy are my other guesses.

Can things be narrowed down by my sampling?

Comment 3

7 years ago
Are you sure that the high CPU usage is caused by Firefox ?
Can you check the CPU usage of each process at different steps :
1. open Firefox in safe mode on the google page
2. don't do anything on your computer and wait until the computer has gone in sleep mode. Wake up the computer
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> Are you sure that the high CPU usage is caused by Firefox ?
Yes, I'm sure the high CPU usage is only Firefox—it was the Firefox-specific CPU usage was I referring to in the first place. The rest of the computer is (usually) not affected. Given that I have 4 cores, I suspect that the process-specific CPU percentage is only referring to one of them, and the other three are able to handle the rest of the applications.

> Can you check the CPU usage of each process at different steps :
> 1. open Firefox in safe mode on the google page
> 2. don't do anything on your computer and wait until the computer has gone in
> sleep mode. Wake up the computer
Are you sure? Like I said, I no longer think it's related to sleep mode. (I haven't changed the bug summary yet because I don't know what to change it to.)

Comment 5

7 years ago
(In reply to comment #4)
> I no longer think it's related to sleep mode. (I haven't changed the bug summary yet because I don't know what to change it to.)

modifying summary
Keywords: stackwanted
Summary: Firefox 4.0b4 uses 100% CPU after waking from sleep → Firefox 4.0b4 uses 100% CPU

Comment 6

7 years ago
I observe the same on a under MacOSX 10.6.5 32b dual core: CPU raises suddenly at 100% (of one of the cores) and FF behaves strangely:
 * some keystokes or mouse events don't work anymore: 
   * page scroll impossible with key but OK with mouse, 
   * tab switching behaving the otherway (key OK, mouse not).
 * the tab-bar behave erratically: 
   * new tabs are not visible
   * deleted tabs are left visible but are not reachable
And FF was too slow for me to wait for a normal quit.

With FF4b7 this became very frequent (mean lifetime before bug ~1/2h), *at some point* so it could be related to a corrupted profile or too many tabs (I have now 70 tabs opened).

It became much less frequent with FF4b8, and each time after a wakeup.
I attach some process sample to help the debug.

Best regards.

Comment 7

7 years ago
I can't see how I can attach the sample files.
They are available on http://polywww.in2p3.fr/~boudry/Public/FF/ with (hopefully) explicits name.

Comment 8

7 years ago
(In reply to comment #7)
> I can't see how I can attach the sample files.
> They are available on http://polywww.in2p3.fr/~boudry/Public/FF/ with
> (hopefully) explicits name.

This seems to be transitional state linked to the number of opened tabs: having reduced a lot my number of tabs (70→20), I sometimes (every 10 mins of so) see a spike in activity (100% CPU for ~10s, but no more blocking for minutes as was the case before).

I attach new sample files for study.

Best regards.
Vincent.

Comment 9

7 years ago
Created attachment 501959 [details]
MacOSX activity monitor sample file (%age of CPU by thread).

Updated

7 years ago
Keywords: 64bit → qawanted
Summary: Firefox 4.0b4 uses 100% CPU → Firefox 4.0b4 uses 100% CPU with large numbers of tabs

Comment 10

6 years ago
Boudry, do you still see this with version 7 or newer?
Summary: Firefox 4.0b4 uses 100% CPU with large numbers of tabs → Firefox 4.0b4 uses 100% CPU with large numbers of tabs after resume from sleep
I was not able to reproduce this on:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:2.0b3) Gecko/20100805 Firefox/4.0b3
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:2.0b4) Gecko/20100818 Firefox/4.0b4
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

In plus this issue is not reproducing on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0.

STR:
1. Set you're PC sleep time to 1-2 min to not wait for a lot.
2. Open 6 tabs:
tab1: www.cnn.com
tab2: www.engadget.com
tab3: www.amazon.com
tab4: www.yahoo.com
tab5: www.soccerway.com
tab6: www.youtube.com/html5

3. Switch tabs random and wait until PC goes to sleep.
4. Wake up PC and switch again random tabs.
(In reply to MarioMi from comment #11)
> I was not able to reproduce this on:
> 
> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:2.0b3) Gecko/20100805
> Firefox/4.0b3
> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:2.0b4) Gecko/20100818
> Firefox/4.0b4
> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:2.0b5) Gecko/20100101
> Firefox/4.0b5
> 
> In plus this issue is not reproducing on Mozilla/5.0 (Macintosh; Intel Mac
> OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0.
> 
> STR:
> 1. Set you're PC sleep time to 1-2 min to not wait for a lot.
> 2. Open 6 tabs:
> tab1: www.cnn.com
> tab2: www.engadget.com
> tab3: www.amazon.com
> tab4: www.yahoo.com
> tab5: www.soccerway.com
> tab6: www.youtube.com/html5
> 
> 3. Switch tabs random and wait until PC goes to sleep.
> 4. Wake up PC and switch again random tabs.

Same results as in Comment 11 for FF 19b2 and Latest Nightly (2013/01/18) on Mac OS 10.8
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.