Last Comment Bug 593435 - [Inspector] Unable to return focus to form elements when another element is selected
: [Inspector] Unable to return focus to form elements when another element is s...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www-archive.mozilla.org/wallet...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-03 11:56 PDT by Aaron Train [:aaronmt]
Modified: 2011-07-19 10:38 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Aaron Train [:aaronmt] 2010-09-03 11:56:53 PDT
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6pre) Gecko/20100903 Firefox/4.0b6pre

Visit the sample form: http://www-archive.mozilla.org/wallet/samples/sample1.html

1. Enter a name in the name field
2. Enable Inspector
3. Try typing into the field while Inspector is focused on the particular field
Comment 1 Aaron Train [:aaronmt] 2010-09-03 11:59:38 PDT
Forgot a step. With Inspector enabled, focus/select on a separate field, and then try focusing/selecting back in the name field. In that case, one is unable to focus back to type in the name field.
Comment 2 Kevin Dangoor 2010-09-03 18:51:55 PDT
It seems to me that perhaps you shouldn't be able to type into any fields while using the Inspector.
Comment 3 Dave Camp (:dcamp) 2011-07-19 10:38:05 PDT
Looks like this was fixed by bug 642471

Note You need to log in before you can comment on or make changes to this bug.